iOS beta app thread


also, once you finish global search, instead of leaving you in the file you started off in the first place you end up with no open file and have to go to the open file dialogue to get to anywhere meaningful


Furthermore I now have one file that won’t open - I just get the spinning dynalist icon - although other files are opening OK

Is this the best place to report bugs in the beta app? Wouldn’t it be easier to have a new topic for each possible bug?


Also - internal ios links - such as Evernote://… - will not open Evernote although they work fine in ios safari. Tapping on them gives no result.

As I use workflowy / dynalist to organise Evernote this is an important feature for me


Here is the best place, since it’s in beta testing.

If you post in the bug category, it would confuse users who don’t have access to the beta yet. This also gives us a better way to see all iOS beta related reports in one place.

Is that file a lot larger than the other ones that you can open?


Yes, considerably bigger although I can’t quantify it at the moment.

Thinking about it, that could be why search everywhere fails for me - because it is trying to search the large inaccessible file.


Some feedback after using some more

  • I wish there was an indicator of it syncing. Or some idea that it knows it’s out of date. When I load up the app I have to wait a bit until I feel confident it won’t keep updating on me while I type.
  • I also agree the search is a bit buggy. Going in to search, searching, and then trying to get back out is often a major pain. There are also points where it hangs with no indicator.


There’s a status indicator when you open the main menu that would say it’s saved or not. If not, there option would say “Save now”. Otherwise it’s a greyed out “Saved”.


Ah I see it now. I think it’d be good to show it somewhere as well without a menu. The desktop web version does this and it’s useful. On mobile with possibly bad connectivity it’s good to know what it’s doing (if anything)


Hmm, this bit interests me.

So there are two error screens, one says “No document is open” and tells you how to open a document; the second one says “Can’t find the document”, and that’s mostly likely because you’re logged out and trying to access your own document. Or if you somehow entered the wrong document id.

So as I understand it you’re running into the latter error page rather than the former?


Hi Erica,

Happy Friday!

I reinstalled current iOS beta last night. It worked fine at home and then I went to bed. This morning it worked fine without any issues.

Arrived at work around 7:30 AM. When I opened Dynalist I was shown the No Document Is Open screen. I am unable to get to my main document no matter what I do.

To note:

  • things worked great on my home WIFi
  • “no document” error when using Dynalist iOS on work WIFI
  • This also stopped working when I left work and went on cellular (noted on my last post a week ago).
  • I am using Google for account authentication
  • I have an iPhone 6 running iOS v 10.2.1

I’d be interested to know if this issue is happening to folks who don’t authenticate with Google for their Dynalist account.

As before I can only uninstall and reinstall to work again on the beta iOS version.




That’s terrible… I hope we can get this sorted out soon :frowning:

That could be what’s happening, but I really double it has something to do with Google login, from what I know about how login and sessions work.

So the left menu doesn’t open? Or as you said, nothing happens when you try to open a document?

It could be that an error has happened which prevents you from opening the document, so we’ll keep an eye on that.

We all go to bed and switch networks, so I wonder what’s special about your case. Your document doesn’t seem particular huge either. I’m feeling worried and bewildered at the same time… o.O + :C


Sorry, the left menu opens but I am unable to access the document I was previously using. I can access most of the documents in the left menu area except 1 additional. So 2 documents are not accessible and I get the infinite loop animation page for them.

Inaccessible Document titles: MICHAEL POTTER and Journal for Feb 2017

  • I initiated a logout > login process back at home that evening - no problems with that process in the beta app
  • I am able to create a new document in beta iOS in this state and it syncs over to the web version fine.
  • interestingly, the Bookmarks also don’t work (they are mostly set for the MICHAEL POTTER document
  • Even more interestingly, I can edit the name of the inaccessible document and it syncs to the web version but is still, well, inaccessible.

I’m feeling worried and bewildered at the same time [/quote]
Hey no problems, it’s beta and I signed up for it. I’d be more than happy to troubleshoot or experiment with this issue so please feel free to contact me if I can help you.


Thanks for the update.

Accessing larger files now works for all my files (although only once I had deleted the app and redownloaded it - is that standard for ios betas? When I just updated the app I still couldn’t access the larger files (366K).

Global search now works fine.

You are probably aware that:
evernote links still don’t work in the app.
A ‘local search’ which turns up nothing has to be retyped once the ‘global search’ is selected.
Date formatting is great in the web app, but doesn’t yet apply to the ios app.

Thanks for all the hard work


The newest app is still in beta review and will be available soon. You can test it on mobile Safari to get a sense of the performance (it’s not exactly the same but it’s close).

Yes, we haven’t starting recognizing them yet.

Search in general needs to be improved, but yes this is one of the problems.

You mean the new Pro setting for custom formats?


Yes, the Pro setting

Actually spoke to soon on the large files. Just downloaded 1.0.15 and I’m getting the spinning dynalist logo again if I click on the large files


Hi Erica, I’m also experiencing the same issue on beta 1.0.15. It happens after I stop using my iPhone for a period of time and come back to the app. Typically the iPhone locks after 3 minutes.

When I unlock my phone and open Dynalist, I see the “No document is open” screen. If I attempt to select another document and go back to the original document, I get a spinning Dynalist logo.

  • My main document is tiny so I know the error is not because of file size.
  • What is consistent for me is using the beta app, putting my phone down for a period of time and coming back to it later in the error state. I’m wondering if iOS or power settings (sleep) is affecting the app?

As a test, I will delete the beta 1.0.15 and reinstall it.
I’ll disable the auto lock settings and force the screen to stay on
I’ll respond to the post if I am locking up or not over a period of a few hours.


The results of my test thus far is I am having no problems with beta 1.0.15 since changing the auto-lock setting to never on my iPhone.

Settings > Display & Brightness > Auto-Lock

I made this change about 12 hours ago.


Good news!

So the clues seem to say that this weird behavior is somehow related to the auto-lock feature of iOS. Maybe iOS does something special when the phone is locked that affects Dynalist.

Thanks for the pointer, now we know a lot more about this issue!


Global seach does not work for me on the latest beta. I just see the logo indicating that the app is working.


[quote=“Erica, post:79, topic:328, full:true”]
So the clues seem to say that this weird behavior is somehow related to the auto-lock feature of iOS. Maybe iOS does something special when the phone is locked that affects Dynalist. [/quote]

Just for giggles, I am turning on auto-lock to see if I can reproduce the issue. It might help push this error into a corner and help define it. I’ll update you later today.