iOS beta app thread


Maybe a clarification of my comment would help here: I meant that an iOS app would have the functions of the web app but also provide swipe, share extension, import/export from other iOS apps and connections to iOS services like calendar, contacts and images.

While not a game changer features themselves, it would make the iOS customer segment happier but require an iOS programmer on staff. These things can be added in the future without losing paying customers now (like WorkFlowy lost me).


I’ll second Chris’s comment about split screen support. I am also using app on a 12" iPad Pro and support for this is critical.


The content sync is also a bit slow. Meaning that the first time I have been making new entries from a browser interface and then switch to my phone the new entries appear slow enough that I see them appear one at a time. While this is happening the scrolling also becomes very jerky. The happens on both my iPad Pro (12") and iPhone 6.



Great point. We’ll look to add split-screen support for the iOS version!

We’re working on that. As you might’ve guessed, we need to do some native stuff to tell Apple we’re taking over several built-in shortcuts.

Interesting, I didn’t know iOS had such a feature. I’ll test that out. Do you happen to know what this feature is called?


How do you request beta app access?



Thanks for your interest. Dynalist and iPad pro have the potential to be a killer combination. Regarding the COMMAND feature I mentioned, please see this link:

and the subheading “How to view app specific shortcuts with the Smart Keyboard”.

One other thing, could it be possible to use the custom keyboard shortcut features of the pro version to work around the conflict with the native apple keyboard shortcuts?



Sorry, that’s not possible.

Basically, Apple is not telling Dynalist that “Tab” was pressed at all. Instead, it just moves the cursor to the next input field, as its default action.

Custom shortcuts work by interpreting shortcuts differently using your preferences, but in this case we didn’t receive anything to begin with, so it won’t work.


@Erica in the Dynalist iOS app, saying “newline” literally does insert a return character into the item. I suspect items aren’t supposed to contain return characters, but in this case that’s what it does.


I have experienced this twice now. Deleting the app entirely and re-installing from TestFlight resolves the issue temporarily, but it recurs.

One of my documents stops working in the iOS app.
The “Everything” doc just shows the loading infinity sign forever.
All my other docs open just fine.
Tried quitting and re-launching the app, didn’t fix.
“Everything” opens in Chrome iOS app, but not in Dynalist app.
It’s larger than others, could it be hitting some size limit?


Ok, thanks for the report! We’ll make a test document of a similar size and see if that works.


Something weird happens to me that no document is opened when I open the app but my main file is clearly selected already.


This is a blocking issue for me in using the iOS app. For now I’m back to using mobile browsers for Dynalist.


This is also happening to me and I’m also switching back to the browser for normal working operation. Erica please let us know if you need something tested in the app to help you troubleshoot the issue.



Is your problem exactly the same as @Ken’s, i.e. it crashes when trying to load a large document, but works fine for smaller documents?


Erica, no my issue is different. My app does not crash but if I stop using it for an hour or more and then attempt to access it, I see the logo animation screen. I eventually just close the app and try again. When the animation screen “completes”, I will see a screen that’s asking for a document location and can’t see the document I was in before.

Lately my 2nd attempts have not worked.

UPDATE Thursday, February 23, 2017 12:09 PM

I’m in my car using cellular data and attempt to open and use Dynalist beta app.
I get the spinning logo (let it go at least 4 minutes) and then an error page…"cant find the document"
In this case, the document that it can’t open was the last one I used
I am able to switch to another document and open it…but not all documents them will open.


That’s the issue I mentioned right? Or another one?


Yes cmp…identical to you I think!


Sorry I missed this… I can send you an invite if you’re interested.


A minor point here:

I normally type in a search, find nothing in the notebook I’m looking in and then decide to do a global search.

I can’t do this in the ios app. I get the option to do a global search before initiating the search, but the option disappears later on. If I want to convert to a global search I have to cancel the original search and start all over again.


Actually a few bugs here…

Global search results in both icons appearing in the top right hand corner of the page mixed together.

Global search also seems to get no results, just a spinning dynalist icon, even if I know I should get a positive result