iOS App is slow & “jerky” when typing in it

Steps to reproduce

Open up the iOS app and start typing

Expected result

Characters appear on the screen as soon as I press each key.

Actual result

There is significant lag between pressing the key and the screen responding. At some points when typing I can be typing 2 full words ahead of what is actually displayed on screen. The characters on screen seem to update quickly, then pause for a second and the screen freezes, then moves quickly again, then freezes for a split second again, etc.


Tested this on iPhone 6s and iPad mini 4 mobile app, same thing happened on both.

To eliminate the possibility my device is slow I also tested typing in other apps - they responded just fine. I also tested typing in my Dynalist document but via the web app in Chrome for iphone, this also worked as expected and characters appeared on the screen as quickly as I typed them.

Additional information

Sometimes pressing into a line to start editing it also has a significant delay between pressing the screen and the action occurring (eg being able to edit the line).

Additional comments


Which version of iOS are you using?

iOS 11.2.5 - the latest version available at time of writing…

I see, iOS 11 has brought lots of issues, like this and this.

The app wasn’t the fastest before the iOS 11 update but it was a little better at least.

Right now we’re in the process of upgrading the entire app framework in hopes to fix this and related issues, so please stay tuned! :slight_smile:

1 Like

Hey Erica,

+1 for this issue.

Adding a couple of observations:

  • I have a single “work” document (around 500kB+) in which typing using my bluetooth keyboard on iPad is incredibly laggy.
  • When typing into a new, empty document this lag is absent

I understand that the jerkiness of the iPad app is probably directly correlated to the size of the document in working memory, and I’m happy to try and organise around this when possible. However, in this instance I don’t really want to have to split up this “work” document as I wouldn’t be able to do a search across all documents (assuming I’m on iPad where there appears to be no global search option; also assuming that I want to perform a search only on my work documents which on desktop wouldn’t be possible either).

I appreciate the work you guys are doing to improve things on the platform - but are there any workarounds for the specific search use case I outline here? Otherwise the only solution I see right now is to suffer the slow typing issues.



Hi John,

If you’re feeling laggy only when editing one document, it’s probably a display issue rather than a memory issue. Basically, too many elements are present the screen and that makes typing every character and tapping every button laggy.

Could you try collapsing unused points or zooming into the point you’re currently working on, and see if that helps?

500 KB doesn’t seem like a lot though. Is it possible that you have lots of checked and hidden items that are not counted? If you could tell me the exact name of the document, I can take a look at the exact size as stored on our server (won’t look at the content).

I hope that helps!

Hey Erica,

If I understand you correctly, I don’t think it’s a display issue - the reason being is that I’ve tried going deep within the document and the issue is still present. I created a version of the document you can test with - it’s called DYNALIST123456789ERICA.

PS I’m not too sure how to figure out the exact numbers, but I’m fairly certain there are minimal checked or hidden items.

Added observation: this may be obvious to some, but I’ve only just observed that the bluetooth keyboard lag is only affecting the Dynalist iOS app. When typing into the Dynalist webpage UI (Chrome iOS), the typing is just fine.



Hey @Erica, any thoughts on this one? I appreciate that this issue may only affect a minority of users (iOS + keyboard) but it’s been causing me so much frustration I’ve had to temporarily migrate back over to that ‘other’ outlining app. Please help!

I’ve had to resort to using “other outlining apps” for input on the go. It seems that using a bluetooth keyboard may be part of the problem?

It could be due to the fact that you can type faster with a Bluetooth keyboard. That would make the “jerky” feeling more obvious.

Also the OP didn’t mention Bluetooth keyboards, so it’s likely that it’s not related.

Correct, it’s unrelated to Bluetooth keyboards but it does affect them to a greatee degree given higher input speed.

Any updates on this team?

Hey all, I hadn’t checked on this thread for a while but for me the issues has been fixed for a while now. I’ve been quite happily using Dynalist app on my phone for the past few weeks, input speed is fast enough to keep up (I’m not using a bluetooth keyboard though), good job Dynalist team! The only bug bear for me now is the delay when opening the app after a while and it takes a while to sync and this seems to interrupt your ability to input stuff if you are inputting into a list that is syncing, but this is a separate issue that I am pretty sure the team is already working on.

Nothing since the last performance update in February (link). There seems to be an improvement for most users, I’m sorry to hear that you’re still having the issue.

Can you describe the kind of lists you’re working in? Does it only happen in large documents? And does it help if you collapse large lists?

Thanks for the update! That’s reassuring to know.

Yeah, sorry about that. How long would the interrupt persist for? In other words, how long is each freeze? And how long does the on-and-off freezes last for?

Hey Erica! I’ve added a video of the typing delays here in case you’re able to have a look? The video shows a moderate to fast typing speed being delayed then eventually crashing the app.

Hopefully the video shows all the lists are collapsed and there’s not much going on on-screen. The document name might also help with repro. Thanks!

I’m having this issue as well and just upgraded my iPhone to fix this issue (6 => 7) but that didn’t really seem to help : /

I’m seriously considering switching back to Workflowy until this is fixed… : /

Hi, still experiencing massive lag with Bluetooth keyboard on IPad making it unusable (letters scrambled), at the same time, no lag if accessing dynalist via Safari. Any hope of resolving the issue ?

Hmm that’s interesting, the app and safari should have been using the same backing engine so it’s really weird what’s happening to you.

Have you been noticing this for a while already? And are you currently on the latest version of the app (1.3.8)?