Dynalist on Iphone 7+ with IOS 11.0.3 hanging on startup

Steps to reproduce

  1. Delete Dynalist App
  2. Power Reboot Phone to be sure
  3. Re-install Dynalist
  4. Start Dynalist and login
  5. App comes up first time no problem.
  6. Edit and add new line of text onto lists, etc.
  7. Close the app, then reopen.
  8. The progress indicator spins for a second then just hangs on the startup screen.
  9. Closing and opening again Same behaviour - app now bricked

The only other thing I can think of is that my data or cache or something like that is somehow corrupt.

Is anyone else experiencing this?


I am running Iphone 7+ with IOS 11.0.3

1 Like

My only workaround is to keep the app open and try never close it. When for seem reason I have to close it, I then need to reinstall it completely and then it work for just the first time :frowning: - what could be wrong?

Having the same issue. Tried opening Dynalist in Safari and Chrome on iOS with the same result (basically, the app is not usable on the phone).

Problem still there after upgrade to IOS 11.1

Sorry for the reply, just saw this…

So this freezing issue is the same outside the iOS app, as long as it’s on iOS 11?

I tried latest version of Dynalist app and now IOS 11.2 - app now opens but hangs when entering return - sometimes is reboots, but not usuable

It is odd that people are not seeming to have this issue, but I am unable to use the IOS app at all? Is anyone successfully using Dynalist on IOS 11?


This might be related: https://www.reddit.com/r/apple/comments/7bsub7/what_happened_to_ram_management_in_ios_11/

Under the 3rd reply someone mentioned that 11.2 made it a bit better, which matches your description as well.

My guess is that iOS has gotten a lot more aggressive with memory usage and that makes it not work with bigger lists at all.


Is this issue any better in the latest versions, namely 1.2.0 or 1.2.1 of the app?

It is much better but there are times when the app freezes up. Nothing works even stopping and starting app. Tried it again a bit later and it then works so not sure what the factors are causing it to hang. Will keep trying and give more feedback if i have any insights.

Thanks Wayne!

We didn’t pinpoint the exact issue behind the iOS 11 freeze, but we did do a lot of performance and memory optimization, so hopefully this problem will appear less frequently and even disappear in the future as iOS 11 keeps improving.

Thank you for looking into this. Right now, scrolling any list of a sizeable length is difficult in the iOS app, as it keeps reloading and taking you back to the beginning of the list (unless you scroll really really s l o w l y ). That said, better than crashing altogether which seems to have been solved :slight_smile: Lately I’ve been using the 3rd party Dynawrite app, which doesn’t have this issue.

App is still freezing for me :frowning: - And it restarts - today it is no go: does not work at all.

Sorry to hear that!

As a next step, we’ll make all animations faster, and hopefully that will make the situation better.

In my situation, it repeats loading and whiteout. Using iPhone X(OS 11.3) and Dynalist app

Hi Takashi, at this point it’s likely a memory issue. Please see my reply over here: IPad App Reloading - #15 by Erica

The IOS app hangs if I open it after not using it for a while. It stays frozen for a while, then crashes. After then restarting it, works fine. I hope we can fix, as the functionality is working well and convenient. As it takes to long to get going (waiting for it to crash before using it) it is not practical. For now I am using a paid app Dynawrite to get around access on IOS.

By “not using it for a while”, do you mean it’s out of memory cache for a while, or that it has been in background mode for a while?

Also I’m curious how Dynawrite does it. Is there any lag/freeze issues with Dynawrite?

Once I start using it after the crash it works for as long as I need it to. The next time I come back to it, e.g. after a day, it will freeze and repeat the crash behaviour.

I have not seen the freeze behaviour with Dynawrite. The UX is not as smooth as Dynalist IOS though, so would prefer to use Dynalist. It’s main feature is a super-quick capture to inbox for notes on the fly.

1 Like

IOS is still showstopper for me, as it constantly freezes when starting to use it. How many people are experiencing it? Am I somehow one of the few to get this? Is there no workaround?