Windows app (Win 7) only showing blank window

Steps to reproduce

Launching Dynalist Windows app, online or offline, in Windows 7

Expected result

App launched, synced, and worked fine since initial install. I didn’t use it for a couple of weeks and when I tried it today I got a blank window. Uninstall/reinstall/reboot didn’t help.

Actual result

Instead of the expected result, what happened?
Dynalist opens a completely blank window. After closing this window, Task Manager shows that Dynalist is still running. Killing with Task Manager and relaunching doesn’t help.

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Windows app 1.0.1 on Windows 7

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments

I see this too. I would only add that after installing I only got as far as a screen asking me to login and taking me to the Dynalist login page. Then the blank window mentioned by the OP. The app never synced once, nor did I once see any GUI elements.

Hi guys,

Do you guys still experience this in the more recent versions?

Nobody seems to report the blank screen problem now, just want to make sure it’s gone.

Hi Erica,
Works fine–I’m using Dynalist right now! Thanks for fixing this.

1 Like

Thanks so much for confirming, such a relief! :slight_smile:

Works fine now for me, too. Thanks!

1 Like

I’m getting a blank screen in win 10

If all your data is synced to the cloud, please try the following:

  1. Make sure local data are saved (you can export local unsaved changes to OPML or plain text using the “Export” option in the item menu);
  2. Exit the desktop app;
  3. Rename the following folder “data” to “data-backup”
    Windows: %APPDATA%/Dynalist/dynalist/data
    Mac: ~/Library/Application Support/Dynalist/dynalist/data
    Linux: ~/.config/Dynalist/dynalist/data
  4. Restart the app.

Hi Erica thank you for getting back to me.
I’ve tried what you asked for and it still comes up blank.
Btw I also have the app installed on other laptops and it works fine so far, only on this particular desktop.

@Jun_Wang: sorry for the late reply, are you still having this issue?

I no longer have this problem, I forgot how I resolved it, but I think one of the suggestion above helped. Thank you.

Fubar …Desktop Application not working.
Windows 7, 64-bit, 16Gb RAM
Launched today and seemingly after syncing it then goes blank-white.

I can still access via web browsers -Chrome, Firefox.

I will troubleshoot more tonite, but I tried things I found on the forums here, but no-go.

Maybe anyone seeing this will have more suggestions.
right now I got:

  • download backup
  • rename data folder so it redownloads
  • reinstall
  • I also tried emptying my temp directory under the user

::extreme disappointment::
Twohawks

UPDATE: There are no controls on the (blank white) page, but if I issue Alt-Arrow command and navigate away the interface fully populates. If I navigate back into that page, it goes blank again.

I will be troubleshooting later with replacing content, etc.

Seems to be some sort of limitation with the Desktop application (again, running Win7 64-bit with 16Gb RAM).

I went into the document via Chrome Browser and

  • cut some data out from the past several weeks =>no result
    so that meant to me nothing to do with a “sudden bad/rejected character” or “length of file” either ‘number of lines’ OR file-byte-size’ …kinds of things.

  • Then I collapsed some major sections => and that corrected the issue.

So there seems to be some sort of “length” limitation (?) either in displayed number of lines OR size* when displaying.
size in number of lines? or size in bytes*?** …who knows.

I tried looking up if Dynalist has any set limits in these regards, but found nothing.

If you see this, @Erica, perhaps you can chime in. Thank you.
Twohawks

Update with some data:
Document has MORE THAN

  • 6490++ lines
  • and more than 245,535++ characters
    (updated)

What browsers did you verify can still open it? The app uses Chrome (Electron/Chromium). Perhaps firefox can open larger documents if it uses less RAM than Chrome.

Hey BC, yeah, I can open in Chrome and Firefox. Its the Desktop Application where it goes “blank-white” on me.
I’ve been scratching my head if there’s some way the Dynalist app is either limited in memory access Or may be being somehow blocked from accessing memory it needs …which we see happening at times when you’ve been running Windows for long periods. I will have to update my post after I’ve had opportunity to reboot -which I don’t do often because I am a power user and running many workspaces concurrently.

Thanks for chiming in. I will update my original post too.

Look in Task Manager and see how much memory it’s using.

If you split your document in half, if will use half as much RAM. That might fix it.

It does look like Electron (the dynalist app) uses more RAM than chrome and firefox for the same document - http://roryok.com/blog/2017/08/electron-memory-usage-compared-to-other-cross-platform-frameworks/

Thanks BC. Yeah, while I am not ready to reboot I did kill some workspaces and run some tests (releasing and checking RAM).

None of the workspace-quits / releasing RAM mattered. Usually that only matters when I’m topping out RAM use anyway, but since it I’m not, and since that didn’t work, I wont have definitive insight on that until I reboot (not ready for that yet -too much suspended work in play right now).

I am only running about 6GB to 7GB RAM (out of the 16GB) during all these tests.

Launching Dynalist Desktop App ‘launches’ 3 executables named Dyanlist.exe. One uses about 75MB RAM and the other about 55MB Ram. The third one quits rapidly during end of Application load(ing).

When I collapse all entries in Chrome Browser, then sync, when the Dynalist App syncs another Dynalist.exe process executes and ramps up to about 350MB Ram.
After Syncing it remains, and drops down to about 250MB RAM (these are in the “working set”), and then it stays there.

Then if I return to Chrome Browser and expand everything back and sync from there, returning to the Dynalist Desktop App (DDA) we observe the 3rd process that was at 250MB Ram drops out of taskmanager, and then the DDA Window goes blank.

EDIT: OH, and THEN, if I conduct the collapse in Chrome Browser and then switch to DDA (and wait and see the list reappear) AND THEN EXPAND all siblings there (in DDA), immediately the “3rd Process” that was at 250MB exits out (in TaskMan) and the DDA window goes blank.

I have no idea. Windows 7 is pretty old, and Electron 13 is pretty new. But who knows.

As a practical workaround, You could, alternatively, use Chrome’s menu > More Tools > Create Shortcut > New Window to create a pseudo-app (PWA app) when on dynalist’s website.

Very interesting, thanks BC.
Just for the record, that page runs about 400MB RAM in Chrome Browser, whether “regular” or “PWA” mode.

I appreciate your chiming in and reflections -thanks again.
I will definitely post back after a clean restart -but that may not be till next week. (Its a huge inconvenience re-establishing lots of workspaces -gotta be outta the heavy lifting work zone when doing it ;^)

My biggest document is 7090 lines, 52,770 words. No issues. It is a bit slow if I expand-all (but I don’t do that.)

Windows 10, running app, Chrome, Edge. About 600MB is used by the app.