Unable to use LaTex code correctly in Dynalist

In normal case, Latex use $…$ to highlight the formula in the text.
For example
it is shown that $x^2$ is right.
But, in Dynalist, such sentence could not show the formula correctly.
The formula could not show unless I change the sentence like this-
it is shown that $$x^2$$ is right.
Could the developer do something for this bug?
I wish your change as soon as possible.

This looks to be by design, not a bug: Make LaTeX "display" style default

Thank you for your reply.

In fact, the design you mentioned would not interrupt anyone who only take $ for dollars.
The reason is that only the $ which follows another $ in the same sentence could make the code shown as formula. That means only one $ would not interrupt anyone.

Therefore, I hope the developer take my advice into account.

I want to keep double $$.

Which would you rather see as the default:

Consider that most people don’t use latex. (I even managed to write all my math papers and physics thesis without touching latex. Thank you mathematica.)

Does your favorite LaTeX editor use single $ math delimiters? Does double work too? Perhaps change that in settings, or switch to an editor that defaults to double $$ delimiters.For example https://upmath.me/

Generally double $$ is the default for LaTeX rendering on the web, see the mathjax and katex libraries for example


1 Like