Squares instead of images

Steps to reproduce

  1. Open iOS app
  2. Upload an image from the Gallery

Expected result

In image or an icon to expand the image is shown.

Actual result

See the strange box at the top.


Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Additional comments

Renders just fine in Dynawrite.

There a few other bug reports for this (example: Bug or feature? Mobile app inline image is a square), but we have never been able to reproduce this issue. We must be missing something.

Do you have the “use Wi-Fi only” option enabled? I see the “4G” in the status bar.

And have images ever worked before, or have they always been like this?

You are right, that was my first time uploading images from mobile. But both “Use mobile only” and “Use true black” under Mobile settings were unchecked.

Actually, just tried uploading over WiFi and I get the filename in the box after the upload. But there are still two problems:

  1. The images can only be viewed by opening a web browser, which shows me a 403 page until I log in again in the browser (a problem given that I browse Private Mode in Safari). Is it possible to view the images w/o leaving the app?
  2. The images do not upload if I try to insert them at the end of the list. See the video in PM.

With WiFi disabled, images seem to upload fine too (again, not to the end of the list)… Heisenbug!

P.S. Apologies for not finding the original thread.

Could it be because the network cached the 403 result?

Also, you can try turning on the “display images inline” option, might help in your case.

1 Like

Nope, not caching in the network. But when you mentioned caching, I logged out and in in the mobile app and now images render well and I can insert images to the beginning of the list. Still can’t insert them at the bottom of the list…

And thanks, inline option is very good!