Relative Dates are Off by One

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Enter some dates:

  • 2018-07-31
  • !(2018-09-03)

Configure relative Display

Expected result

What do you expect to see after carrying out the steps above?

  • 1 Day Ago
  • Today (no time specified, so 15 hours ago is not right)
  • In a Day
  • In 2 Days
  • In 3 Days
  • 2018-09-03 (distant dates, I would rather see the actual)

Actual result

Instead of the expected result, what happened?



Chrome Windows desktop

Additional information

Switch from Relative to Default and the same date switches display from “3 days ago” to “2 days ago”

I’m open to other opinions on treatment of the September date. For the other days, the above description (or equivalent with other words) is the only right way to display it.

The current time of day should not matter unless we are talking about today, and then only if a time is specified.

Open question to readers: For past/future dates,should time be displayed?

Additional comments

It would be VERY helpful to document the date/time format option, as I struggled to change it.

Also I would like to see the Time want to see time only if it’s entered !(2018-03-02 2:30). I can configure to always show time (a waste of space 95% of the time) or never. I can’t get !(2018-03-02) to display differently format from above. This would apply with relative formatting or absolute. There is ONE way: use the default. That works pretty well in fact.