New checklist behavior?


#1

Toggling the checklist does not anymore make the selected item a checklist item. Only the children are now checklist items.
Furthermore, the current behavior seems to have issues as it does not work all the time: Sometimes not even the children become checklist items.


#2

I’m seeing the same issue. Also, if you use the keyboard shortcut to change to ‘Make Checklist’, nothing happens, but the dropdown menu changes to ‘Unmake checklist’ even though no checkbox has appeared. It looks like the system thinks it’s made the change but no checkbox appears.

Hope that helps


#3

I think this may be an intentional change. There’s been a discussion over here about making only the children of a checkbox item have checkboxes, much like the way only the children of a list item have numbers.


#4

So as Craig pointed out, part of this change seems to allow us to create checklists where the parent item does not have a checkbox. If that’s the case, that’s a really appreciated change!

However, this change has made it frustrating to add checkboxes to individual items. I do this often for mixed lists (i.e. lists where some items have checkboxes and others don’t). Now the ‘Make Checklist’ option on individual items doesn’t do anything immediately. Instead it seems to lock the item from being changed when you Make/Unmake Checklist on its parent item?

So now I need to select any items that I don’t want to have checkboxes and select ‘Make Checklist’ on them. Then selecting ‘Make Checklist’ on the parent item will add checkboxes to any of the items that I didn’t select.

If I want to later add or remove a checkbox from one of those items, I have to select ‘Unmake Checklist’ on the parent to remove all checkboxes, select ‘Make Checklist’ on the item, and then select ‘Make Checklist’ again on the parent. Hopefully that makes sense. It’s really confusing!


#5

Yes, it’s an intentional change. It has been “wrong” for years, and now we’re fixing it.

For everyone who relies on this wrong behavior, please use this advanced setting:


#6

If you want an item to have checkbox, make its parent a checklist. Or if that’s not an option, see my post above to revert to the old behavior.


#7

I agree that’s a valid concern. I think that is more related to the other ticket though:


https://trello.com/c/yoj6qb8o/75-force-item-to-not-have-checkbox (106 votes)

In any case, I don’t think that adding checkboxes individually is the solution. Based on the nature of outliners, all items in a “checklist” are checkable items. You might want to “escape” a few items, but that’s the exception, not the norm.


#8

I would suggest, since this is the new improvement, that the menu item also be improved from Make Checklist to Checklist Children, just like Number Children. If this had been the case, I would not have had to come search for a “bug.” Rather I would have known immediately it was a change and I would have known what to do.


#9

Good idea! We’ll make the option text clearer as well as post a PSA about this. Thanks for the suggestion!