iPadOS 13.4.1

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Open and start typing

Expected result

What do you expect to see after carrying out the steps above?

Responsive typing

Actual result

Instead of the expected result, what happened?

Super laggy typing.

Environment

Which operating system are you using?
Which browser are you using?
If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Are you using any third-party scripts for Dynalist, e.g. PowerPack?

iPadOS 13.4.1 (the one with mouse support - yay)


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments

Did this just start happening after you made an upgrade from an older version of iPadOS?

Yes. I can confirm that I see the same behavior on my iPhone as well when upgraded to iOS 13.4.1

Got it, we’ll upgrade our devices soon to investigate the issue, thanks for the report!

1 Like

I’ve updated our test iPhone to 13.4 17E255 (I can’t seem to find 13.4.1 as it says I have the latest update). Haven’t seen any issues with the app performance wise compared to before. Our iPad is updating currently, but only to 13.4 as well.

I’m guessing 13.4.1 is a beta? I will test again once a new iOS version is released.

I just tried again (and I’m running on 13.4.1 on my iPad Pro). I see the same performance problem with my primary document. When I create a new document though, I don’t see the problem. My primary document is pretty big - 243KB compressed. Perhaps related to the length of the doc? Have you tried it against a large doc?

That’s certainly a large enough size I would recommend avoiding on mobile, but if you say it worked fine on previous versions of iOS then that’s still quite suspicious. I’m upgrading our test device again to see if we can repro.

Updated and still not seeing an issue so far. Were you able to test if the issue goes away when you split the document up into smaller pieces? Hopefully that can give us some clue as to what to look for.