iPad Smart Keyboard Arrow Keys Don’t Work




I’m just trying out Dynalist, but iPad keyboard support is going to be a blocker for me :cry: I just want to point out that Outlinely did find a way to support arrow keys (but unfortunately lack some of Dynalist excellent features…).


Hi Arunaud,

Thanks for the input! Making this work in one of our top priorities, so good news for you! Just look out for our new app updates and it should arrive really soon :slight_smile:


Thank you Erica! Do you have any good news or expected release date? :hugs:


No release date, sorry about that. But it’s one of the top things we want to fix! :slight_smile:


This is great to hear. Keyboard support for iPad would really simplify life!


Hi Erica,
Still no news ? it’s been month now…

Up and down arrow keys change function to move to start/end of item instead of previous/next item

Sorry, @Clement_B! This is still on our todo list, and it’s pretty non-trivial to fix.

We’ll be sure to update here once we make progress on this one!


Hi Erica,
Thank you for the effort. Any good news yet?
If it takes more time, could you plz insert the keymap menu for dynalist iOS version?
That way, we can at least assign the up and down function to another key combination.
Thank you.


Not yet, but very soon! I’ll be sure to update here once there’s news on this :slight_smile:


Hi Erica. Just to point out that today Things 3 has just received a massive iPad Pro update. They seems able to resolve the problem with the arrow keys. Just pointing that out in case this is helpful. You may want to take a look at the app, they have done wonders with the iPad Pro keyboard navigation. If Dynalist iOS app can go to that direction that would be awesome!

Thanks for all your hard work :grinning:


Things is a native app, so the situations are a bit easier for them. For now, at our scale, we can’t afford to build a 100% native app, sorry I hope that’s understandable!

Still, we’ll try our best to solve this issue! :muscle:


@Erica thanks to your team for fixing this issue. I now can use up/down arrow with my external keyboard and suddenly Dynalist feels like a real app on my pad. This was a big fix for me. Thank you!!!


Great! :star:

There are still a few hiccups that we’ll fix soon, like the landing position after pressing Up/Down is still not quite accurate. But we wanted to release it as soon as we can so people can start benefiting from the fix :blush:


@Britt_Selvitelle: This should be fixed in the latest versions (v1.2.6), could you please confirm when you have time? Thanks in advance!


Thank you for the update! Now I’m moving to Dynalist from Workflowy!


This is fantastic. Thanks for adding this, what a game-changer! Now, if only there were a way to zoom in and out of bullets with the keyboard…


Are Ctrl+[ and Ctrl+] not working…?


No, that combination doesn’t work for me sadly. Using a 3p keyboard (Logitech) set to US English. Can you link me to the docs for iOS external keyboard shortcuts? To be honest I wasn’t aware that there were any up until recently.


Can’t zoom in using the shortcut Ctrl+[/] either. I am using Logitech K380 on iOS 11.4. Hope this is not off-topic. It might be better to open another thread for that.
Anyway, thanks for your work on fixing this arrow key issue!


Documentation is the same as other platforms: https://help.dynalist.io/article/91-keyboard-shortcut-reference

Because iOS intercepts many shortcuts, some of them are not working. Tab, Shift+Tab, Up, and Down are all cases that were intercepted by the iOS system.

More complicated shortcuts like Ctrl+Shift+M to move should always work.

And yeah, what @joegnis said, if the zoom in/out shortcuts are important to you, I’d appreciate it if you could open a new topic on it :slight_smile:

iOS external keyboard shortcuts for zooming don't work