IPad App Reloading

Steps to reproduce

Just having the app open on iPad 12.9” 2017 with the latest iOS version

Expected result

The app should work and not reload the whole content roughly every 10 seconds

Actual result

Reloading the whole contents of the document every 10 seconds and if typing loosing up to 10 characters that were typed before the reload


OS: iOS 11.2.6
Browser: Safari
Dynalist Version: 1.2.3

Additional information

I can upload a video of the problem.

Additional comments

Hi @Nick_Davitashvili,

If you don’t mind, uploading the video would definitely help. (Or if you prefer to do it privately, email to support@dynalist.io.)

If you don’t mind me asking, what’s the name of the document? As we hear from other people, the reloading issue has something to do with the size of the document.

Here’s the video @Erica

Same thing has statted happening in the app for iPhone…very frustrating

I’m seeing exactly the same issue on both the iPhone and iPad for any document I’ve tried to edit. Makes the app unusable.

Yes. It’s happening for any and all documents. The size of the document doesn’t seem to be a parameter.

Hi @Nick_Davitashvili and @Adrian_Savage,

Could you guys please uninstall and reinstall the app and see this issue goes away?

If it does, it might be related to the local session data not working correctly. Please uninstall only after making sure all local changes are synced, thanks!

Hi @Erica,

Reinstalled on iPad and seems to be working alright for the time being, but even prior to today it was intermittent, so needs to be monitored.

I’ll let you know if it comes back on the iPad.

In worse news, the re-install didn’t help on the iPhone… Any other ideas?


Re-install is usually tried first to rule out the possibility that the cause of the problem lies in the local data, because in that case, it’s nearly impossible for us to repro the issue on our end.

If that doesn’t work, with your permission, we’d log into your account on our test device to see if the issue is reproducible. As long as we can make the issue happen on our test device, the rest of work is just to debug and fix the cause.

If we don’t get an account to test with, we’ll generate huge documents locally and try to repro the issue with the information provided in this thread… Repro’ing the issue is half the success!

Don’t mind you logging into my account. I’m ok with an idea of being a product to all the cloud services :slight_smile:

Also I’m super secure/obscure and I write everything as if it’s gonna get released by Wikileaks. :slight_smile:

Just don’t delete stuff please.

And the issue is back on iPad again…

I see, then it’s not related to your local cache. That way we’re more confident to repro the issue on our end.

I’ll update here if we find anything. Really sorry for the inconveniences, @Nick_Davitashvili @Adrian_Savage!

Is there an update to this, please, @Erica? The app is still restarting on my iPhone after a reinstall and i can’t use Dynalist at all, even with a very small document it’s restarting.

P.S. I’ve just reinstalled again to do more testing and even when I go to the file list and use the search function there, the app reloads/restarts even when I’m just typing a search term. You have my permission to use any of my data needed for testing as long as nothing gets deleted.


The cause of the issue is most likely a memory-related one. Although you’re opening a small document, all documents are loaded into memory for tag count, tag autocomplete, and Search Everywhere to work properly. When an app uses over 100 MB of memory, iOS kills the process and hence the reloading issue.

I can try identify which are the biggest documents in your account, and the issue should go away if you export them and then delete them. In the previous case we looked into, the person had a few full books and a copy of Bible in his Dynalist, which caused the out of memory issue.

Having reloading issues on my iPhone during first few minutes of use. Then gets better.

This does not seem to be a scalable approach. After years of accumulation problem will impact more and more people. Interesting challenge, as the search function is vital, but may need incremental or otherwise managed search database or indexes (server side)?

I checked my documents for larger ones. I deleted Propædia which was something interesting, but I do not use it that often. Will monitor impact on IOS.

Yeah. Or not load the entire thing until global search is activated. It’s also a challenge that some people want global tag complete (tag autocomplete with suggestions from other documents) and cross-document link resolution :frowning:

Another hope is that iOS will give us a way to get more memory. At least if the user decides to grant us more memory. Right now, as we understand it, our app gets assigned a certain amount of memory. The iOS system just won’t give us more. Apps like Safari use memory though, which is why the web app runs a lot faster on Safari, for the same functionality.


We’ll always keep that document in demo. Feel free to copy it back whenever you want to play with it.