iOS app - new line bug

Steps to reproduce

In iOS app I find that every so often the app stops responding to the return/new line key, i.e. It will not create a new empty line below, it just ignores the key press. The only way of dealing with this is to restart the iOS app. I see this behaviour pretty regularly on iPad Pro 1st gen and iPhone X. Its pretty frustrating

Does this happen for the external keyboard or for the on-screen keyboard?

Most of the time I have the problem on the iPad with Apple’s Smart Keyboard Folio.

Ok looks like we’ll need to find one of those… I don’t seem to have any issues with the on-screen keyboard on my end.

I experienced the bug again today whilst using the Apple Folio Keyboard on the iPad. So straightaway, I disconnected the keyboard and activated the virtual iOS on-screen keyboard, and this too had the same problem, namely the carriage return would not create a new line in the Dynalist iOS app.

I’m not using apple’s keyboard but a cheap third party Bluetooth keyboard on my iPad and I have the same problem. So its probably external keyboards in general

I just experienced the same problem in Google Chrome browser, on macOS. This time a blank indented line could not be changed (new line did not work, back space to delete did not work and shift-cmd-backspace did not work. A ctrl-R refresh fixed it. Starting to wonder if it might be a device / platform independent bug?

Since you’re seeing this on macOS I’m guessing it might be something Apple related? I’m not hearing reports about android/windows/linux, and I would assume such a noticeable bug would have been reported by other users.

Though actually this behavior sounds very strange - I recall hearing about a similar issue long time ago when some action actually put the app into a mode where it doesn’t think it’s editing, and the app stops responding to (override) actions properly.

Is there any chance you can recall if any specific actions will lead to the issue happening? It could be something like performing a search, or opening a pane, etc.

Just happened again. This time on iMac (macOS) using the Dynalist Mac app. Quitting and restarting the app fixed it (as is the case on iOS too).

I think I have an idea which part broke, but I can’t figure out what actions leads to the breaking.

Have you noticed any patterns of what you did that leads to the issue?

The only thing I can think of is that it never happens when the macOS / iOS Dynalist app / Chrome Mac app starts. Its always after I have been using it for a bit.

Just happened again on MacOS using Chrome browser. A refresh of the browser fixed it

I’m experiencing the same issue on my iPhone XS (no external keyboard) as well.

Unfortunately I haven’t seen any sort of pattern which might trigger the effect.

Killing and restarting the app fixes the issue for the moment.

Yeah a restart should fix it, but I’m still wondering what may have triggered it.

So we now know its more than one user, not external keyboard related and problematic in iOS app, Chrome and Safari browsers. Hopefully that will help you to narrow it down?

That helps rule out external keyboards (thank god!), but I’m still having trouble finding the right codepath that leads to this issue. If we can nail down a pattern of what action leads to this, it would be really helpful! Thanks!

There is no common precursor that I can discern. I’ll keep watching for this though.

Thank you. Please keep posted. Really appreciate your patience on this.

Today I noticed that the delete line also suffers this bug. i.e. cmd-shift-del ⌘-⇧-⌫. After a bit of use in Chrome and/or the native app it wont delete the line. A refresh fixes it til the next time.

Also very interestingly the functionality cmd-del ⌘-⌫ which only deletes the part of the line to the left of the cursor, continues to work even before the refresh mentioned above.

My non-programmer logic tells me that something in the core app (not a specific client) is leading to the return key :leftwards_arrow_with_hook: or occasionally del key ⌫ being disabled or not recognised until the core app is refreshed (taken out of memory and then replaced in memory?).

I hope this helps your bug hunting.

I’m fairly confident that it’s caused by a bad scope push/pop, causing the app to think it’s in a different mode (for example, in search mode) so it’s not catching the key events correctly.

I’m just looking for the exact steps where I can follow the same steps to put the app into this bad mode, so I can know where it happens.