Copy/Cut tree

Steps to reproduce

Select an item with subitems, but the item is collapsed. (variation: select multiple items)

Press Ctrl-C to copy.
Create a new node and press Ctrl-V.

Expected result

I expect an exact duplicate of the item(s) and all subitems.

Actual result

I only get the visible item(s) copied.

Environment

Using MS Edge, in Windows.

Additional information

Additional comments

(see also Copy/Cut/Paste context menus)

Maybe this should be a separate bug, or not. I just discovered if you paste in a tree copied from elsewhere (but the tree is expanded so the subitems are also copied) , the pasted items are in different order from the original.

This bug does not always happen. I tried again and this time everything appears to copy correctly. But the other time it was very mixed up.

Can’t repro, you’re pasting into Dynalist right?

When I tried the steps I get a collapsed item. After expanding it, it looks the same as the source item being copied.

And how are you selecting it? Ctrl+A once or twice?

Have you changed copy/paste behavior in the past week? Things are not the same today.

Yeah, a little, mostly to stripe empty<b> and <style> tags.

So is the bug still reproducible now?

We had some other feedback about a certain copy paste bug. It only happens on Firefox, not Chrome though.

Using MS Edge:

Select:
image

Copy, Ctrl-C. Then add a blank item. Then paste:
image

Same procedure, same computer, Firefox:

image

Chrome is also good like Firefox.

Urgh, ok, looks like it’s a MS Edge bug then.

Could you please edit the original post to change the “Environment” info? Thanks in advance.