Checklists not visible


#1

Hi there,

Last week the checkboxes for checklists disappeared from my dynalist. I can still see them fine on my phone, but not on my desktop.

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Mac, running dynalist in the browser, chrome.
Use the shortcut to make something a checklist (that has been working fine for a year), or use the gui menu select “make checklist”.

Expected result

What do you expect to see after carrying out the steps above?

The item becomes a checklist and shows the square box

Actual result

Instead of the expected result, what happened?

The item does become a checklist (I can tell as the context menu becomes “unmake checklist” isntead of “make checklist”. However, the square box is not visible. I can see the changes on my phone

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Mac OSX Mojave, 10.14.5

Chrome and Safari


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Myself and my team use Dynalist Pro for work, and this is affecting us every day. Please prioritise fixing it. Many thanks.


Additional comments


#2

I am facing the same issue on Windows 10 Pro (Version 1803 - OS Build 17134.829)

Using Chrome Version 75.0.3770.100 (Official Build) (64-bit)


#3

I think this is related to a recent change to checkbox behavior. If you prefer the old behavior I think you can change it in the Advanced section of the Settings dialog:


#4

@Sam_Jones @Jonathan_Ward: please see Craig’s solution. We’ll get a PSA out soon so everyone knows about this change.

We’ll also make the menu option more clear (e.g. “Add checkboxes to children” rather than “Make checklist”).


#5

Perfect! Thank you! This worked for me.


#6

Thanks guys, this worked. I have been thinking this was a bug for the last week or so and have switched to using the mobile version, with the hope that the desktop version would be fixed soon.

In retrospect, this change may have been less confusing if the option in the settings had been enabled by default for users, to preserve the functionality most people were used to.

Anyway, good to know that this was intentional!