Can't set separate "Zoom in"/"Zoom out" keyboard shortcuts on Mac/Windows

Steps to reproduce

On Mac, set Zoom in / Zoom out keymap to Alt+] / Alt+[ (delete default mapped keys). On PC keep it as default Ctrl+] / Ctrl+[ (delete default mapped keys).

Expected result

Mac/Windows versions respect the separately assigned keybindings.

Actual result

For both Mac and Windows the keybinding is set to whichever setting was configured last, they aren’t isolated for each OS.


Chrome for Mac/Windows.

For context, I want Ctrl+] / Ctrl+[ on Windows as that’s the default, and on Mac I need Cmd+] / Cmd+[ to be unbound so that they can map to Chrome’s “backwards”/“forwards” shortcuts. Chrome also has Cmd+Left / Cmd+Right mapped for “backwards”/“forwards” but I use that to jump around spaces in MacOS, so it’s already in use.

It seems like usually Mac/Windows keymaps are isolated, so I’m not sure why the settings are forcing Cmd = Ctrl bindings to be present on both.

Keymap config is shared between the two. We don’t currently support local or platform specific config yet.

If you set a shortcut with Cmd on Mac, or Ctrl on Windows, it would be setup as “Cmd or Ctrl” depending on which platform you’re on. This is just because the convention of the platforms.

However, if you set a shortcut on with Ctrl on Mac, it would actually be saved a “Ctrl” only, and will be bound to Ctrl on both Mac and Windows.

I’ve also moved this to help since I think it better categorize this.