Cant delete doc on android

Steps to reproduce

Try to delete document

Expected result

Document is deleted

Actual result

Document is not deleted



Additional information

Hi Steven, I can’t seem to repro this.

I opened the menu of a document and selected “Delete”. After confirming, the document is gone.

Are you deleting it with or without internet?

I have internet. The document appears deleted for a second but then reappears

Is it a shared document or just normal document?

Sorry for the late reply!

It is a normal document.

Ok, I tried but can’t seem to repro the issue. Tried new and existing documents.

Is it happening for only one document or all the documents? If it’s just one document, do you mind telling me the name of the document (or PM me the name)? Thanks in advance!

Hey Erica,

It is only happening for one document, and it turns out that the document only exists on the Android App and not on the desktop or web app. I have renamed the document on the app to “Delete_bug”, although it’s possible you won’t find it on the cloud.


Hi Steven,

From the backend, it looks like the “Delete_bug” document has been deleted (that’s the information recorded on our server).

Could you please try clearing the cache for the Dynalist app? Sounds like the local data is corrupted somehow. Don’t worry, this won’t make the data lost, the app will pull a fresh copy from the server. As long as all the changes you did on mobile are synced to the server, it’s fine.