Cannot use arrows to navigate in Firefox

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

  • Open any dynalist from Firefox (on Ubuntu 14 LTS, Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0). Doesn’t have to have wrapping items, even short items exhibit this behavior.
  • Try to navigate using up and down arrows

Expected result

  • Move to next item with a down arrow, move to previous item with an up arrow.

Actual result

  • Move to start of item with an up arrow (and then stop). If the item wraps, moves through each wrapped line but then still comes to a stop at the beginning of the item.
  • Move to end of item with a down arrow (and then stop). If the item wraps, moves through each wrapped line but then still comes to a stop at the end of the item.

Environment

Which operating system are you using?
Ubuntu Trusty 14.04 LTS

Which browser are you using?
Firefox Quantum 66.0.3 (64-bit)


Additional information

Up/down arrow navigation has never worked in Firefox for me and I had been assuming that I just don’t know the right keyboard shortcut, so from time to time I would look for explicit documentation of how to move between items and had no luck.

Just now I tried it on Google Chrome and arrow navigation worked as normal. Also worked on Linux desktop client. Also tried it on Pop!_OS 18.04 LTS with 72.0.1 (64-bit) and it worked there as well.


Additional comments

Firefox seems to be at v72 right now and while testing with Firefox 72 on Windows, I didn’t seem to run into your issue. Not sure if it’s a Firefox issue or a Linux specific issue. Any reason why you are on v66? (I know 66 is not that old, seems to be march 2019, but I’m still just trying to rule out any issues about Firefox version first)

Also, do you see any errors in the developer console when you use up/down?

I cannot arrow navigate in FF or Chrome (Win7). Just downloaded and testing Dynalist last couple days. I am hoping this is a temporary bug and not how it works, or we cannot use it.

This is otherwise such a nice project, indeed.

Update: tried it on a few other computers and platforms -same result.

Hi HTHawks. I’m running Dynalist on Chrome on Windows 10, and arrow navigation is working fine for me. Is it possible you’ve got a browser plugin interfering with your keyboard?

Thanks Craig (and I didn’t miss your post in my other thread either ;^)
Interesting…
I tested extensions off and even some services disabled in the systems with same results. I wont be able to test on a win10 or Apple system until weekend or next week.
Cheers.

In case this helps: I’m running Firefox 72.0.2 on Windows also and have not encountered any difficulty navigating.

Okay, figured out what was wrong, silly me.

I just noticed have the Arrow Key Guard Greasemonkey script installed. As soon as I made an exception for dynalist.io, the problem I was having went away and now I can use up/down arrow navigation normally.

Silly me.

Thank you for your responses, this issue is resolved.

2 Likes