Calendar integration

I see calendar integration has been turned on in Settings. When will it actually sync? OR maybe more importantly, how often?

[Moderator Edit - JP1]

Be sure to:

  1. Link to your Google Account (again)
  2. Choose a Calendar :date:
  3. Edit the document’s settings to enable the ones that should have dates synced to Google Calendar.

Please wait for the official announcement, which will answer all your questions. I’ll post a link here when it’s out.

2 Likes

As promised, here’s the link: http://blog.dynalist.io/gcal-integration/

Let me know if you have further questions! :slight_smile:

1 Like

This looks fantastic and it’s working perfectly for me!

If we want the event to have some duration do we have to change it manually in google calendar?

2 Likes

Thanks for letting us know!

Yes, for now.

Think of this as a v1.0 for dates & calendar integrations. We do have plan to add support for date range and recurring dates (https://trello.com/c/2jvhpLQT/140-pro-recurring-tasks) in the future.

2 Likes

This is such an awesome feature, and I’m looking forward very much to date ranges and recurring dates!

3 Likes

@Erica Can we make it so items with a date but not a time are “all day” events rather than instantaneous events at midnight?

1 Like

Very cool feature!!!

One tiny bug, when I refresh the calendars in config, it adds to the list instead of replacing.

This feature alone is worth the pro pricing.

1 Like

Hi I have some questions:

  • When I delete a date in Dynalist the event is deleted from gCal?

  • When I update a date (or time) in Dynalist the event is updated from gCal?

  • This gCal integration (after setup) works only on WEB? Or mac app / mobile apps works too?

1 Like

Yeah we’re thinking of changing that in the next iteration.

1 Like

That’s a quick bug report! (Only a few hours after the release!)

Looks like a straight-forward bug, will fix asap!

1 Like

Refreshed and followed the steps …but I do not see the link described in the directions to “turn on” calendaras listed in the instructions noted below. Right-clicking on the document does not show this available…I am using Chrome…should that matter?

Right click on the documents whose dates you want to sync, and choose “Turn on Google Calendar sync”.

Thanks
Rick

Not working for me. I’ve got the connection set up fine, but nothing appears in Google calendar. I’ve tried making new items with dates in the future and see nothing. The setup in Dynalist can see my list of calendars fine.

If it helps any, if you implement the ability to send in content by email and parse the subject line to extract a date, a service like FolowUpThen.com is available to supplement the need for recurring dates. Just throwing it out there.

2 Likes

Did you turn on for the document you want? i.e. step 2 here: http://help.dynalist.io/pro-features/#google-calendar-integration

The reason is that we don’t want to assume you want to sync all documents. For some people, it would crowd their calendar as some dates never need to show up there.

Have you chosen a calendar to sync to in the dropdown in settings?

Yes… The selected calendar shows OK, but there is no link to it when I right click on the document

That’s weird. It seems to be working for everyone else.

You’re on the web version for all three steps right?

Thanks. I should really read instructions more carefully. Working fine now!