Zooming Out From A Child Node Does Not Set Cursor

Steps to reproduce

  1. Zoom in to a Parent Node that is collapsed
  2. Put the cursor on a child node
  3. Use keyboard shortcut to zoom out

Expected result

I will be zoomed out and the cursor will be placed in the parent node, so I can continue working with keyboard-only

Actual result

The cursor is not placed, I have to use my mouse to click the cursor into where I want it


Which operating system are you using?
Mac OS Catalina
Which browser are you using?
Chrome and Desktop App (tested on both and bug is same on both)

If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Are you using any third-party scripts for Dynalist, e.g. PowerPack?

Additional information

Screen recording of the bug here:

Additional comments

Currently zoom-out is designed (not accidental) to keep the cursor in the same place it was.

It used to work the way I described in “expected result”

In all other outliners I have tried it works per “expected result”

I don’t see any advantage to the way it currently works, Dynalist is designed to be usable as a “keyboard only” experience but this bug breaks that usability.

I agree, it seems like a bug to ever have a “dead” cursor that doesn’t respond to up and down arrow. As a workaround, any of these hotkeys should “revive” your dead cursor. “Go to start of first item” is probably the most intuitive of them. image

Will be fixed in an upcoming release.


Thanks this works! Although at first I tried “Go to parent item” and that did not work. But, as you suggested, “Go to start of first item” works and so does “Go to end of last item”.

As a side note, as I was figuring this out, I finally found out how to press the “Home” key on my Macbook Pro keyboard… it’s Fn + Left Arrow for those that were wondering!

Haha I actually did wonder this, thx.