Working with images

Hi there. Continuing to enjoy the product. Slowly starting to shift away from others I use. Thanks for all you do.

Trying to understand support for images. A few use cases:

  1. If I right click and “copy image” from a web page and try to paste it into a Dynalist item, nothing happens (Windows app or Web)

2a) If I drag an image from a web page and drop on a Dynalist item, it will drop in, but cannot be resized.

2b) Note this does NOT seem to work in cases where the web image does not have an image extension (such as jpg). For example using this image does not seem to work

2c) If I drop the image into the Windows app, it will not show up on the Web (even after syncing). And vice versa as well

  1. If I manually take a screenshot of an image and then paste that in, it does paste in, but cannot be resized

  2. If I “copy image address” from a web page and paste, it pastes in the URL, but not the image itself. This is probably expected behavior

  3. The link provided for more information at the bottom of this page appears to be dead

Note I do have the display images inline setting turned on.

Could you just generally advise on the above? My most common use case would be #1 above, so for that not to work is a challenge.

Thanks

That’s right, for some reason “Copy image” doesn’t actually copy the image into your clipboard, thus it can’t be uploaded to Dynalist.

Correct, images can’t be resized in Dynalist right now. Also we don’t recommend using drag and drop, it’s the built-in function of the browser, but it’s not supported by us. You should use the image markdown to insert images (like this: ![image name](image url))

It’s probably not recognized as an image?

As I mentioned above, dropped content is not recognized by Dynalist so it doesn’t sync over either.[quote=“JT1, post:1, topic:839”]
3) If I manually take a screenshot of an image and then paste that in, it does paste in, but cannot be resized
[/quote]

Same here, resizing is not supported at the moment, sorry![quote=“JT1, post:1, topic:839”]
4) If I “copy image address” from a web page and paste, it pastes in the URL, but not the image itself. This is probably expected behavior
[/quote]

You can use the image markdown above to correctly insert it.

Sorry about that, it’s the “File attachment” section here: http://help.dynalist.io/article/94-pro-features

Erica thank you for the clarifications

You could just do what I do

I use imagus + shareX to handle all my image assets (.jpg, .png, .gif , etc). Consequently, I also reupload images found on googleimages this way as well

Dynalist file uploader for PDF, .exe, .docx, any other file format goes here:

I have inlined images enabled by default

so I could always use markdown syntax to get inlined images, or just leave them as previewable hovered over images

Never had a problem with this system and works great for me

The only time I drag and drop is when I’m moving a PDF or .exe or .zip or any other non-picture / gif formatted item into dynalist, which is maybe once a week

This works great for me since also all my dynalist-uploaded files are all nonimages /not-gifs making it easier to sort and manage file

1 Like

I tried uploading the photo to be displayed to google photos.
The link works, but not the hover feature.
Any reason why?
44

only electrical permit found

Can you show me the link? Is it a direct image link, i.e. one that ends in .jpg, .gif, or .png?

P.S. Would really appreciate it if you could post a new post, instead of digging up an ancient post. This one is about images, but I don’t see how it’s related to your issue.