Unable to copy spaces in the code block

Steps to reproduce

Manually use mouse to select and copy any code containing spaces from the browser or vscode or dynalist itself, then paste them into the code block in dynalist

code block

Expected result

spaces remain the same as the original code

Actual result

spaces disappeared


Which operating system are you using? Linux
Which browser are you using? Firefox
If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Are you using any third-party scripts for Dynalist, e.g. PowerPack? No

Additional information

Sorry, I could not reproduce that on my computer. See, the tabs are correctly pasted. I also tried 4 spaces in place of tabs which also look the same.

Can you try opening an Incognito window and going to https://dynalist.io/demo to try it there, and see if it still happens there?

I tried and the issue remains. when I copy the same content to mail text editor or vscode the blank/tab are correct

did you click the ‘copy’ button or manually select all text and paste? make sure to manually select instead of using ‘copy’ button in dynalist code block


sorry turns out it’s a vscode issue, ctrl shift v to copy plain text works fine