"Sign in with Google" stopped working in Chrome

Steps to reproduce

Try to log in using Google Chrome using Google account. No popup window to sign in appears.

Actual result

No popup window to sign in using google.
I am getting following message in the web console:

[GSI_LOGGER]: Your client application uses one of the Google One Tap prompt UI status methods that may stop functioning when FedCM becomes mandatory. Refer to the migration guide to update your code accordingly and opt-in to FedCM to test your changes. Learn more: https://developers.google.com/identity/gsi/web/guides/fedcm-migration?s=dc#display_moment and https://developers.google.com/identity/gsi/web/guides/fedcm-migration?s=dc#skipped_moment

[GSI_LOGGER]: FedCM get() rejects with AbortError: signal is aborted without reason

The request has been aborted.

Environment

Tried on Windows 10 Chrome 123.0.6312.88
Same behavior on and also on different machine with Windows 11

Additional information

Everything is working fine with Edge.
Everything is working fine in anonymous Chrome mode.

In common Chrome mode I completly cleaned up all browser caches using dev tools, restarted security settings for the page but nothing helped. It is actually very confusing that Anonymous mode behaves correctly

1 Like

I get the same console warning, but it appears to just be a warning about a future change.

I don’t have any issue signing in via Google.

Try eliminating external factors by using a different browser, in incognito mode. If Google sign in works there, it is likely a browser extension causing the issue.

If all else fails (perhaps your firewall blocks Google or something you can’t easily fix) then there is an alternative way to sign in - click Forgot Password and it will email you a password reset link. Then you can pick a password and sign in via email address.

On a hunch I wondered if you’re in the beta test for Chromes new third party cookie blocking…

Google shares update on next step toward phasing out third-party cookies in Chrome (blog.google)

If I manually turn that on, it seems to break the sign in popup.

You might need to manually enable it for google or for dynalist…worth a try

Delete, allow and manage cookies in Chrome - Computer - Google Chrome Help

I am not aware I would be a beta tester. But I have some 3rd party cookies blocking settings available. I tried to switch 3rd party cookies on and off. Still same behavior. By the way in the annonymous mode where it works I am getting the first and the second error message too. But not the third one “The request has been aborted.”

Anyway I am now logging using user name and possword as suggested so the problem is not blocking. Thanks

Someone on discord https://discord.gg/cUQMdgR actually has the same problem, and I just checked and it’s broken on my chrome too…

…investigating in the chat

If my understanding is correct, Google is, once again, deprecating their login system for a newer library. I remember doing this once a few years back where they disabled their old “Google Plus” account login system, so unfortunately that means I will have to update that again.

In the meantime, if Google Login is completely nonfunctional for you, you should still be able to request a “forgot password” to your email and set a password for your account to login to. I will look into updating the Google login soon.

I’m having the same issue. Using “Forgot My Password” worked.

Having same issue, tried forgot my password and was stuck in an endless loop of captchas. Allowing popups and whatever else in chrome didn’t help, but edge works. Very frustrating.

Advice from a googler who looked at Dynalist’s sign in issue @Shida

gu...@google.com) added comment #7:**
Tested the button flow on https://dynalist.io.

The root cause is that, the website use a button to trigger One Tap UX flow. This is strongly discouraged.
As mentioned in the developer doc (https://developers.google.com/identity/gsi/web/guides/features#exponential_cooldown), One Tap UI may not be shown on every API call, due to cooldown, no-active-google-session, etc.

Please use GIS button flow instead. The doc is at: https://developers.google.com/identity/gsi/web/guides/display-button

1 Like