Searchresults with collapsed notes

Hello together,

I often use the search over all documents to find an item. In the search results all the notes are expanded. It is hard to find what I am looking for, because there are sides of unrelevant notes opened. This is also because I transfer some of my mails to notes.

Is there a way to exclude notes from search and have them collapsed in search result page?

Thanks a lot

Hi FM.
I am not totally clear on the problem.
It appears you have been with Dynalist a long time, so I don’t know if this helps…
Dynalist Search Operators Reference

When I do search over all documents I find I need to use
-ancestor:<some significant word or phrase in a document title or header>
…kind of thing. That excludes those documents or sections for better filtering.

ancestor:<significant word>
…shows all children fullyexpanded

parent:<significant word>
…show only first order children

<significant word>
…show only the node with the word, with children collapsed

If I need to scan through a search results list more effectively than in the Desktop App, I…

  • open the Dynalist Document in a Web Browser
  • conduct the Dynalist Search
  • then Choose the Browser’s “Find in Page” feature and hunt through the list for keywords. You will need to use the Browser’s Menu to execute that ‘find in page search’

LAST TIP: If you add a Search Plugin to your Browser, you can potentially search collectively for various keywords (and in any order) …all highlighted within your search results page.

For instance, in Firefox I can use “Multiple Search and Highlight” plugin to assign several words and phrases to look for with a page.

Does that help?

Thank you very much for your tipps. I forgot about the ancestor-operators. Unfortunately it does not solve the problem exactly, as far as I see. My question was misleading though :wink:

What I need is:
Notes are always collapsed in fulltext search results by default.

Currently they are expanded by default. Is there a way to switch this behaviour or is it a theme-css-problem on my site?

Using search-operators
<search> in:note -<search>
would also do the trick. But this is very unhandy, though :-/

This is quite a late reply, however, I think you simply have to change the setting for ‘Notes’ under ‘View Option’ (eyeball next to the search box), and then full text search will accommodate the selection (show, 1st line, hide) accordingly …unless the result is in a note (and that is not excluded), of course.