Read-only link sharing does not work by default

Steps to reproduce

  • in macOS app under My files, click ‘+’ > New Document and give it some name
  • right click on the document and click Manage Sharing
  • click Share this document
  • a settings screen is shown, where “View this document” is already selected
  • don’t change any setting, just copy the sharing URL and click Done
  • go to a private browsing window and navigate to the URL

Expected result

The Dynalist URL should display without redirecting to a login screen.

Actual result

The viewer is redirected to a login screen, even though the “View this document” option had been pre-selected.

A workaround is to unselect then reselect this option, then the URL can be visited fine by anonymous viewers.


macOS app v1.1.10. (NB: there should be an “about Dynalist” menu entry in the macOS native menu above the app instead of in the dynalist menu (gear button).)

Additional information

sharing settings pane as it appears by default:

When I try sharing a document for the first time, the “View this document” checkbox is not checked by default.

Is it the first time that you share the said document?

For me, the “View this document” is pre-checked, even when I share it for the first time. I just tried again by creating a new document, same result (I’ve updated the procedure above).

I can’t repro, but I did find the root cause of the problem: the checkbox is not updated when you open the sharing dialog, so whether it’s checked depends on the previous sharing dialog you opened. So if you the last document you tried to share has it checked, it will appear checked even though the document is not viewable.

Thanks for catching this!

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile:

1 Like