Random page zoom in Safari on iPadOS

When using Dynalist in Safari on iPadOS, Dynalist will zoom (sometimes to very large sizes) when switching back to Safari from another app.

Latest iOS — 13.4.1

It’s very hard to consistently reproduce, but it sometimes happens when swiping between apps, sometimes when using the app switcher, sometimes when using cmd-tab. Dynalist is effectively unusable when this happens.

The only way to fix the problem is to log out of Dynalist, close the Safari tab, navigate back to Dynalist, and log in again. The problem might re-occur almost immediately, however.

Any chance you can show a screenshot of what the zoom looks like? Is it like two-finger zoomed in or just everything sized wrong?

It’s very difficult to reproduce, on demand! I’ll take a screenshot and update here next time it happens.

In the meantime, here’s a related problem:

All looking good here:

But then the menu is truncated at the bottom:

Cool please keep me posted! There’s a bug report for the menu issue already I believe, so we’ll be tracking that one from there.

Working in Dynalist in Safari on iPadOS. Everything is fine, and looks like the screenshot above.

But then, upon switching back from another app:

As you can see, Safari’s zoom level is set to 85% (my preferred setting):

This could be linked to three-finger swiping (trackpad) between apps.

That might not be the case, though.

Once this weird zoom has happened for the first time, it goes nuts and changes every time Safari becomes the active app.

The only way to stop it is to log-out of Dynalist, quit Safari (and I always clear cookies, etc), then relaunch Safari and log-in to Dynalist again.

So frustrating!

I’m having a hard time imagining something we did could cause this. Any chance you’d run into this same bug on other websites in safari?

I’m also surprised that you have to log-out and log-in! Does it not fix itself it you relaunch safari by killing the app, or just close the tab and open a new one?

The logging-out is probably just habit. I haven’t tried just closing the tab!

Whatever is causing it, though, it’s a showstopper. I had to stop working this evening as I was getting so cross!

And, personally, I’ve never seen this behaviour on any other website…

I did a little testing on our development iPad (13.4.1) and on Safari I can’t seem to get the zoom to happen unless I zoom in manually - If I do that I can still zoom back out with two-finger pinch. Not sure why that happens in your case but I suspect it might be Safari bug. I’m hoping Apple could fix it on their end on the next iOS version update.

Could be. It can happen when there has been no touch interaction at all, with everything going through a trackpad, and I certainly never pinch to zoom.

It’s very difficult to reproduce consistently, but it happens often enough that I KNOW it will start occurring at some point in a session.

I seemed to have reproduced it, still not sure why but I think it’s caused by some kind of “new” Safari feature, which “zooms in” to what it thinks is the article width you’re trying to read.

I’ve added a new tag to the page to force safari not to auto-zoom, while still allowing manual zooms. A quick test shows it’s fixed! Will be deployed in the next few days.

That’s fantastic news — thanks for looking into this.

Is there a way to see when a new version of Dynalist has been deloyed? Is there a version number somewhere?

Cheers,

Steve.

Given you’re using the web version of Dynalist in Safari, there isn’t a version number you can check. Sorry about that - hopefully you’ll find it magically fixed in a few days! (In the meantime I found that you can scroll to the left where the file pane is, then zoom back out using two-finger pinch gesture on the left pane)

I used Dynalist in Safari on iPadOS for about 30 minutes earlier and didn’t encounter the problem! Did I just get lucky, or was this the fix in action?

We pushed out an update yesterday so you’re probably on the new version!

Oh, no! Still happening, I’m afraid.

I think I’m on the latest build — I have word count linked to zoom level.

Don’t know if this is just today’s quirk, but the problem has reversed — the zoom is getting smaller each time I navigate away from, then back to, Safari.

Steve.

I logged into Dynalist this morning with the express purpose of testing this, so that I could give you the clearest feedback possible.

It seems that there is no reliable way to reproduce the problem, but it will occur at some point in an extended use session. The change in zoom level can be triggered by:

  • Switching to another app and back again (swipe/app switcher/tab switcher).
  • Switching to another Safari tab and back again.
  • Switching to a different Dynalist file.

It happens in portrait and landscape, with touch or with keyboard/trackpad.

When Dynalist is affected, other non-Dynalist tabs are not (including this one, the forum, or the Dynalist log-in page). I have tested this with many tabs open.

I usually view Dynalist at 75% or 85% (using the AA button in Safari’s address bar) as the default is too big. It’s possible that this is the root of the problem, but it’s the only way to make Dynalist useful on an 11” screen. I have been unable to replicate the problem when using Dynalist at 100% on a fresh load.

Maybe the answer is just to make the default view smaller. 85% is comfortable, but 75% is probably even better.

I hope this information helps you to narrow the problem down. I’m all-in on both Dynalist and iPad, so having the two work together seamlessly would be incredibly useful…

Regards,

Steve.

Hmm I’ll try to go for an extended use session to see if it happens again for me.

Did you say if you were able to zoom back out/in by using two-finger drag on the file pane?

Thanks for your continued suport.

I don’t want to jinx things or divert your efforts to fix the problem. but since I wrote my last message early on Saturday morning the problem has not resurfaced. I used Dynlist in Safari on my iPad extensively on Saturday and Sunday and did not encounter the problem once.

Maybe I just got lucky, or maybe I’m using a newer build without knowing it. I just thought you should know. I’ll post here again if the problem happens again (I know I’m tempting fate…)

Steve.