Pressing Alt Zooms In Search Results Window Unexpectedly

Steps to reproduce

Open up any Dynalist page in the Windows desktop version and conduct a tag search of a tag that appears on the page. Once the results are displayed, press and release the Alt key.

Expected result

The Alt-key would function as normal.

Actual result

The Dynalist window zooms in/magnifies the size of the window 3 to 4 times.


Windows 10, Desktop app 1.1.24.

Additional information

This seems to happen whether you quick-press the alt key or press and hold and release it. But it only seems to happen when you have conducted a search, and only within the desktop application. It also means that whenever I do an alt-click to remove a tag that is shown in search results, the window magnifies, which is very annoying. Thank you!

Edit: I just experienced an occasion in which pressing the alt key caused the same zooming behavior on a window that wasn’t displaying search results. So apparently this is a more extensive problem.

Additional comments

This is still an issue, although it doesn’t happen every time you press the Alt key. But it doesn’t even require that you conduct a search–it can happen any time you open a new outline level in Dynalist and then press and release the Alt key. It honestly makes the desktop app useless to me because I have to constantly decrease the zoom after pressing the Alt key accidentally zooms in. I really hope this gets fixed!

I have figured out how to reproduce the issue EVERY single time. Open up a Dynalist document in the desktop app and conduct a search of any text that appears in that document. Once the results display, click into one of the nodes of text. Then press and release the Alt key. The entire window will zoom in unexpectedly!

I would be happy to troubleshoot this with any of the developers if you’re unable to reproduce the issue. PLEASE fix this or at least acknowledge it’s an issue! It makes the desktop app unusable for me.

Unable to reproduce your results on my side - Windows 10 as well.

When I press and release Alt, the top left menu bar shows up:

But the app doesn’t zoom in like you described. Couple of things I can suggest:
If the entire interface is zooming in (getting bigger), that means you triggered the zoom in key somehow, which you can find here: (maybe those keys got stuck? I don’t have any other clues)

If you can upload a video of how it works on your side, maybe we can think of something…

Thank you for your response! As requested, here is a video of the problem.


I think the problem might only occur for those of us who don’t use the default zoom level. I like to use around a 75% zoom instead of 100%. What I think might be happening is that pressing Alt somehow triggers the Actual Size shortcut (Ctrl+0 according to your screenshot), because pressing Alt under the circumstances I’ve described always makes it jump to that exact level of zoom. Sometimes, after I exit the search and press Alt again, it zooms back out to my preferred zoom level, so it’s like Alt is toggling on and off the Actual Size shortcut.

One more thing I’ve noticed: the error only seems to happen the first time I run a specific search on a page. If I search for the exact same phrase twice in a row, pressing Alt the second time won’t mistakenly zoom in the app again. In that case, to reproduce the issue, I have to search for different text (and then press Alt) or refresh the page and repeat search (and then press Alt).

Please don’t give up on helping me solve this issue. I have reproduced the bug on two different Windows 10 computers, and I did not have any other software running when I recorded this GIF that might have contributed to the problem, so I am positive it is a bug within the Windows 10 Dynalist desktop app. Thanks again!

Oh yeah I can reproduce based on your description. Will see what I can do to have it fixed.

1 Like

I’ve looked into this further and it seems to be a bug in the underlying platform (Electron) that powers Dynalist. We can’t fix it directly, but I will add an option in the next release which will allow you to turn off the auto-hiding menu, which is a workaround for this.


Thank you so so much! I am so excited for this :smile:

Just to update on this - I did add the menu option but I apparently tested it with the wrong version of Electron so it’s not working for the deployed desktop… Totally my bad but in the next version the menu option should work properly.

1 Like