MOVE command broken by hotkey or menu controls

Steps to reproduce

Chrome: Hitting my hot key combo for move does nothing. It has worked before. Going to the item menu and selecting move likewise does nothing.

Expected result

What do you expect to see after carrying out the steps above?
THE MOVE dialogue.

Actual result

Instead of the expected result, what happened?


Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Latest ver DL, latest vers Chrome, latest mac OS.

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

This has worked reliably in the past. Refreshing the tab for DL or closing and reopening does not make a difference, same results. No move dialogue.

Additional comments

@Fred: can’t repro. Are you using any extension or Powerpack?

powerpack 2.3.4. Still broken days later. Oh, just installed chrome clip-this-page extension but his issue predates that install.

Just checked. MOVE works in Opera (without powerpack).

@Piotr: sorry, refreshing the move dialog for mobile might have broken your code.

Could you take a look at this at your convenience please? Most likely it’s just due to some CSS name changes. Sorry about that!

@Fred: please disable Powerpack to test bugs in the future, and if it happens only with Powerpack, please post it to the PP thread. If it happens without Powerpack, post it under the normal Bug category.

Even if we want to help, it’s hard for us to debug PP related issues. It’s not that PP caused the issue, but rather we made some changes that work fine in Dynalist but didn’t notify @Piotr. This kind of stuff happens :frowning:

“The item “test” was successfully moved under “#archive”.”

I’m using move all the time, no idea what can cause the problem.
Chrome 67 on Mac is broken with some things, my tampermonkey was going crazy with 100% CPU all the time because of this bug maybe it’s somehow related.

Piotr, I did not suspect Powerpack was at issue and still only know that MOVE does not work for the past week with Chrome and PP installed but does work in Opera without PP. It remains to be seen that it is a PP issue. Erica mentions “refreshing the move dialog for mobile” as possible culprit. I’d think then it would be broken for more than me. I will notify Erica: PP disabled on Chrome and still MOVE does not work.

ERica, Powerpack disabled for Chrome but MOVE still does not work. What other info can I provide you?

Sorry, I understood this sentence as Move works as long as PP is disabled.

I tested on Windows 10 latest Chrome. Both the Move dialog and the success message appeared. Same for on macOS.

If we broke it, I think it should be broken on all browsers. That’s why I suspect some extension or adblock is blocking it on Chrome, if it’s not Powerpack.

Could you try in Chrome incognito with all extensions disabled? That’s the fastest way to find out.

Also, the mobile refresh for Move got released around 2 days ago. If it was broken for you for the entire past week, it should be something else.

Chrome in incognito–MOVE shortcut works. I cannot ID any newly installed Chrome extensions that might account for this disappointing loss of function in DL. I suppose I will have to make a special effort to keep an incognito Chrome window (Opera) open for this one function. Heck.

Yeah, damn. Is it PP though? Any chance you can disable only PP and keep other extensions running in Chrome? That way we can see if it’s PP or some other extension.

It doesn’t seem to be PP. With that disabled, still no MOVE.

Heck. The new Chrome clipper won’t be as useful as I had thought since it will now be a pain to sort from INBOX to a topical destination for web research.

Link to another item–still works. Just MOVE is broken.

Not the end of the world. Just puzzling. If I’m the only one with the problem, must be something unique to my situation. I’ll live with it. Still HAPPY with Dynalist!

Not sure if this is gonna help, but a basic binary search would work:

Let’s say you have 16 Chrome extensions. Go to the extension list, activate the first 8 and disable the other 8.

If Move is still broken, narrow down to the first 8. If Move works fine now, narrow down to the other 8 extensions.

Now you 8 extension suspects on hand, divide them into two groups of 4 extensions, activate 4 and disable the other 4. Repeat the process until you find the culprit.

If you have 16 extensions, it will only take 4 tries to find the culprit (assuming one of the extension is causing the issue). If you have 32 extensions, it will only take 5 tries.

If your number of extensions is not a 8 or 16 or 32, just roughly divide. For example, you can divide 9 into 4 and 5.

I hope that helps!

Nailed it. Gmail Web Clipper. I could swear I just installed that a few days ago after noticing Cloud HQ on the header of my (newly updated) Gmail. I don’t remember installing that and wonder if that is a pre-emptive install by Google. I went ahead and loaded a couple of these tools but can EASILY live without the clipper thingy. Problem solved. Maybe this will help someone else. Thank YOU for helping me and sticking with this gremlin til he was squashed!

1 Like

Cool! :slight_smile:

Glad to know it’s resolved now.