Missing newline space when copying from pdf


Steps to reproduce

Copy multiple lines of text from a pdf
Paste into dynalist

Expected result

The text from the pdf is copied as one would expect (with all spaces between words included)

Actual result

The words at the end of a line are joined with the first word of the next line (missing a space)


MacOS Sierra 10.12.6
Chrome 60.0.3112.113

Additional information

Additional comments

Text pastes correctly into every other option I could think of.


I just found out that it works as expected when using “paste and match style,” which is absolutely GREAT because I’ve been adding in spaces for weeks now, but it would still be nice if normal paste worked as well :slight_smile:


Hi @Rachael,

Could you explain this solution a bit more? I tried but I don’t see a “paste and match style” option in Dynalist. Or did I understand that incorrectly?


Sorry, “paste and match style” is a command on MacOS, which I believe is equivalent to “paste unformatted text” on Windows.


When I tried testing copying multiple lines from PDF, what I get is actually a different behavior: each line appears on its separate item…

I’m glad it working for you with “paste and match style” though!


The same thing happens for me when I paste unformatted text copied from a PDF opened in Chrome using their PDF viewer.

So the solution for now is using a separate app to view the PDFs (plus paste and match style), as it’s better than adding in spaces (with normal paste) or deleting new lines (with unformatted paste) when using Chrome. I do wish I could just have my PDFs open in another tab though :slight_smile:


Ah I see.

So “paste and match style” is actually an option in the PDF app, not the browser? Because it says “paste” I assumed it was on the receiver end (vs “copy” which is on the sender/source end).


No no, it’s a standard option everywhere when you right click or go to the edit menu. Sorry if I’m not being clear!

I just meant that the best solution for me at this time is to use a standalone PDF viewer to view the PDF and copy the text, which I then have to paste in Dynalist using the “paste and match style” option. This is the only way I’ve found to get the text to show up properly, as using normal paste joins the words.

I haven’t found any solution that works in Chrome…if I’m viewing the PDF in Chrome, it pastes incorrectly no matter what: When using normal paste, it connects each word at the end of the line with that at the beginning of the next line. When using “paste and match style”, each line from the PDF is entered on a completely new line, as you mentioned.


Hi @Rachael, sorry for digging this up! We’re cleaning up the bugs and would like to know if we can close this now?


Sorry @Erica, it might be useless to answer this now…I was on holiday and forgot to check here :expressionless:

I’ve become accustomed to using “paste and match style,” so I didn’t notice a change. But yes, copying from a PDF app now pastes with all spaces as shown in the PDF! The bad news is that now it always includes 3 or 4 extra bullet points below, so it’s still more convenient to use “paste and match style.”

I also checked for copy–pasting from Chrome’s PDF viewer, which actually now works perfectly! All spaces included, and no extra bullet points. Furthermore, when copy–pasting words that are broken up between lines, it pastes without the hyphen (from the PDF app, the pasted version always includes a hyphen and a space, no matter how it was pasted)