"Make checklist" only makes some children have checkboxes


#1

Steps to reproduce

In a list made before the checkbox change, or with a text copied from a list made before the checkbox change, with “Show checkbox in front of checklist parent” turned OFF, toggle Make checklist on a parent. In the example below I do the toggle on “Ute”.

Expected result

All the 2nd and 3rd level items should get a checkbox.

Actual result

Only the items with sub-items and their respective sub-items get a checkbox:

Environment

Firefox 69.0a1 nightly or Chrome 75.0.3770.100 on Windows 10.


Additional information

If I turn “Show checkbox in front of checklist parent” ON, while the list is in the “made checklist” state, all items get checkboxes as expected. But if I then do “unmake checklist” on “Ute” again I get this:

3


#2

+1 I’m having the same issue. I think this is an important bug that was introduced recently.


#3

+1 – I’m having similar issues, but I’m unsure if it’s related to Dynalist, my Custom CSS, or PowerPack


#4

+1 checklist feature is behaving inconsistently.


#5

+1 checkboxes broken for me too. Can we get an estimate for a fix please?


#6

Sorry for the late reply… I tried a bunch of documents that existed before this change, both on the desktop app and the web app. Couldn’t repro it.

It might be because “Vindjacka” and “Utebyxor” are already set as checklist parents? Can you try toggling them again? That’s the only explanation I could think of that could cause this. If that’s the case, it’s more of a transition issue than a bug (meaning if Dynalist were designed as the new version, this issue won’t happen). There were invisible states floating around that caused this.

You could enable the legacy mode to more clearly see which items previous had checkboxes in front of it.

I guess this can be fixed by changing thing around so that if a checklist parent doesn’t have any children, it would show a checkbox?

@Ignacio_Ocampo @inakarmacoma @Ben_Aldern @Ian_Strandberg_The_E


#7

I forgot to mention that my test case is like this:

  • Test
    • a
      • b
        • c
    • d

First, make “a” and “d” checklists. Then, make “Test” a checklist. You’ll see that “a” and “d” still don’t get their checkboxes.

Is this the issue?


#8

In Mac, CMD + Shift + C isn’t working as expected, checkbox toggling isn’t working.

I have give you a demo of my issue if you wish :slight_smile:

Thanks!


#9

@Ignacio_Ocampo: A screen recording would help.

I want to double check that you know Cmd+Shift+C add checkboxes to an item’s children, not itself, right?


#10

As far as I can tell, I’m having the same transition issue as mentioned above, and yes, your test case is in line with what’s going on.

I realize that it’s not theoretically a bug, but I have such extensive list/checklists (discontinuous) that all got mixed up with the new checklist behavior, and unfortunately the easiest way of dealing with it is checking the setting for “show checkbox in front of checklist parent.” It would just take too long to make and unmake all of the checklists in an order than keeps the boxes in the right places.

However, as the new behavior fails to meet my needs anyway, I don’t feel so bad about having to stick with the old one. I followed the discussion and was looking forward to the change, but it didn’t end up solving my issues with checklists in general. I appear to be in the minority that prefers more flexibility with toggling checklists (I would love to be able to toggle at will!) and likes to have bullet points nested under checklist items (like this guy). Still hoping for a way to make it work someday :slight_smile:


#11

Sorry for the late reply in turn, but I’m in the same boat. I’m happy with the old behavior, and the sudden change of the default way of handling checklists broke stuff for me. It’s probably a transition problem, and as long as we can keep the old style if we want I wont be upset. :slight_smile:

A gripe that I have with the new way is that I can’t really see if an item is a “checklist in waiting” but with no children and therefore won’t get a checkbox (such as “d” in the example above). Can probably be done with some CSS tweaking, but I stick to the old setting instead.