macOS Beta - App opens with blank screen after being forced closed

fixed

#1

Steps to reproduce

  • Have Dynalist open
  • System runs out of application memory and force closes Dynalist

Expected result

  • The application open after being forced closed by the OS

Actual result

  • The application opens with a blank screen

Environment

  • macOS 10.12.2 (16C67)

Additional information

I have tried deleting and reinstalling the application but it still will not open correctly

Screenshot:


#2

Hi there, are you still experiencing this issue? cc@Erica


#3

Hi @Corey_Maylone,

Sorry I somehow missed this – are you still experiencing this issue?

The steps to reproduce is a little hard though… how long did you have Dynalist open before it was forced to close?

Thanks!


#4

Hello,

I was finally able to fix it by deleting the app and all of it’s associated data.


#5

This actually happened to me too and I only just recently starting using the app within the last week.


#6

For a fix please see @Corey_Maylone’s fix above.

Were you in the same situation as @Corey_Maylone? I mean, did your Dynalist run out of memory and got forced to close, or did it close normally?

Thanks!


#7

No it was closed and I started it up again. I see my memory on my task bar and I would have noticed if Dynalist was taking all the memory.

I have not tried deleting all the existing data and reinstalling


#8

I’ve experienced the same issue as cmp and Corey. Deleting beta 1.0.9 version of the app and reinstalling worked for me.

Hours later, the app failed again to update and just showed the logo animation then “No Document is available” message

Update: Wednesday, February 22, 2017 8:39 AM

  1. Launched beta app and screen has been spinning for at least two minutes. (on WIFI)
  2. Closed app and turned off WIFI and turned on Cellular data
  3. Launched beta app and screen still spinning as before
  4. Deleted app and hard restarted iPhone 6
  5. Reinstalled Dynalist 1.0.9
  6. Launched beta app used browser login option on WIFI (Google Account)
  7. Login request authorizing Dynalist account, selected YES. Login successful
  8. Acknowledge Login “Continue” button selected
  9. App working normally

I will update this post if I experience more issues today. :iphone:

Update: Wednesday, February 22, 2017 8:52 AM
Experienced the same issue again after putting my phone down and coming back to it to look at my lists. The Dynalist logo is currently spinning for more than two minutes.

question: I am logged into Dynalist on Chrome (Mac) and the Dynalist Mac app on several computers and leave them on during the day. Could this be a related issue?


#9

This happened to me again after a reboot.


#10

Update:

We spent quite some time investigating the blank screen problem and determined that there are two places where this can possibly happen. We’ve fixed problem 1, and added error message for problem 2 so that it’s more informative. We didn’t fix problem 2 since it seems unlikely, but we still want to confirm whether it’s problem 2 causing the white screen.

Going forward, if you run into the white screen bug in 1.0.21 or higher (when the fix was introduced), please let us know if you run into any more blank screen incidents! A blank screen with an error trace would mean it’s problem 2, confirming our hypothesis. A blank screen with nothing on it would indicate that it’s neither problem 1 nor 2, meaning we need to look harder to find other potential problems that would cause the blank screen.

Thanks guys, and so sorry for the trouble.


#11

I’m also having blank screen on PC app, with no error message, and deleting and reinstalling does not work (although I do not know where the setting file is saved if there is any).


#12

I replied to your post in the other thread. Thanks!