Lost focus when switching documents

Steps to reproduce

Press Ctrl+O to display the document list, type or select a document, press Enter.

Expected result

Able to edit the selected document immediately.

Actual result

No longer in list edit mode. Have to press Tab (sometimes twice in Firefox) to start editing.

I also have to press Esc twice to cancel the document list and start editing again. The first Esc only dismisses the window.


Windows 10, Firefox 54, Chrome 59.

You probably want to enable “Focus on first item when opening doc” in Settings - Preference - Advance settings.

We had a poll a while back and most people don’t want this behavior, so we changed it to an opt-in thing. The problem is that automatically focus will also un-render the Markdown, which many people find annoying. I know you rely on keyboard but many people don’t – I hope that’s understandable!

Link to the poll: https://twitter.com/DynalistHQ/status/855423145385373697

1 Like

I do have that option enabled (since I found out about it Keyboard not functional when starting Dynalist).

You’re saying you have the option but the focus doesn’t happen? I can’t seem to reproduce that on my end.

I have that option enabled. The list now starts off focused when I go to dynalist.io (with the option disabled, it didn’t do this). But with Ctrl+O, type characters or up/down arrow keys, Enter to open a list (a different or the same list), the focus does not go to the list.

Hey Kyle,

I found why this is happening! I’ve made a fix for it and it should be deployed within a couple of days.

1 Like

I still have a similar problem when I open a bookmark that is built on top of a search query. The focus is lost unless I use the mouse. I do have the focus on first item advanced setting turned on. Any thoughts on what I can do?

Two quick questions:

  1. What typo of bookmark is it? Is it search, global search, document, or item?
  2. Are you using mouse or Ctrl+O switcher to go to bookmark?
  1. search (“within:today”)
  2. Ctrl+O switcher. btw, it also doesn’t work if I use the mouse.

And that’s within a document or globally?

That’s within a document.

I can confirm that’s happening – will fix as soon as we can!

Hi! I know this is an old thread, but I am new(ish) to Dynalist and also having this issue. I’m using ctrl+o to switch between documents, and I’d like to be able to start editing without using the mouse. Is there a keyboard shortcut for switching into edit mode? I’ve been trying to search for this but I haven’t found anything yet (maybe I missed something). The “focus on first item when opening doc” doesn’t work for my case because some of my documents are somewhat long, so I’m usually switching from somewhere in the middle of one to somewhere in the middle of the other.

1 Like