Link to Windows directory crashes

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

  1. enter a link: [:file_folder:Files](C:\Users\seidl\Gutachten\Tagungen)
  2. click this link

Expected result

What do you expect to see after carrying out the steps above?

The target directory opens in a new windos of Windows file explorer. This desired behavior worked throughout the last year until the last update (a week ago or so).

Actual result

Instead of the expected result, what happened?

Windows alerts a Java error, see screenshot:
grafik

Environment

Which operating system are you using?
Which browser are you using?
If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Are you using any third-party scripts for Dynalist, e.g. PowerPack?

Windows-10
Dynalist Windows App 1.5.0 (upated last week)
No additional scripts


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

(screenshot see above)


Additional comments

Linking to Files, Folders, Mails, etc. is an important feature for me that allows me to configure Dynalist as my control center.

Additional Issue: Links including a whitespace didn’t cause problems either in former versions; that seems to have changed as well: [:e-mail:Outlook](outlook://seidl@ifi.lmu.de/Beratungen Muenchen)

Maybe the devs need to change openItem to openPath in electron 10 but idk just a guess https://github.com/electron/governance/blob/main/wg-api/spec-documents/shell-openitem.md

Good catch!

Hi Dynalist, is it enough to reload the window, or do I have to reinstall the app? (when will the fix be available?)

I think the fix isn’t live yet, but it’ll be up in the next update, sorry about that!