Intermittent like-bugs in Windows desktop app, which are auto-solved after restarting (app or Windows OS)

Steps to reproduce

Unfortunately I couldn’t find out yet how to reproduce the bugs exactly, but I can say that after 2 days of intense use of Dynalist Windows app a couple of intermittent bugs have appeared. Each of the following bugs appeared in different days, but by chance at the end of the day, after Dynalist Windows app is ON during many hours.

Bug 1 - Document or global search using operator “is:heading” wasn’t working in Dynalist Windows app. I tried many times. Inserted and removed headings in many items and no search output at all. Then I tried the same operator in Dynalist web and the search result worked as expected. Returning again to Dynalist Windows app the operator was still not working. After restarting the app, the operator “is:heading” started working properly.
Note: In that case just restarting Dynalist Windows app worked.

Bug 2 - The following operations involving mouse stopped working:

  • Duplicate Item (Ctrl+mouse drag)
  • Delete Tag (Alt+mouse click)
    I tried Dynalist web, and the operations worked properly there. I closed/restarted Dynalist Windows app many times, but the bug was persistent. Then I had to restart Windows OS, and after opening Dynalist the bug disappeared.


Dynalist for Windows (1.0.52)
Operating System: Windows 10 Pro 64-bit
CPU: Intel Core i7 5500U @ 2.40GHz
RAM: 8,00GB Single-Channel DDR3
Motherboard: Dell Inc. 0PYXMC
Graphics: Intel HD Graphics 5500 (Dell) + 2047MB NVIDIA GeForce 830M

Additional information

Although not direct reproducible, maybe others are facing intermittent bugs like these when using Dynalist Windows app.

The desktop is usually behind the web app by a few days. We have been trying to communicate this at the beginning of each weekly update.

When in doubt if it’s a delay in release or bug, you can restart app to double check or ask us :slight_smile:

Still not working on Windows app after the bug 1 is resolved?

It was resolved after Windows has been restarted. Just closing/restarting Dynalist didn’t solve the issues involving mouse operation.

However, today I just turn on my computer (it was hibernated, then a “clean” Windows OS start didn’t happen) and Dynalist issues involving mouse operation has appeared again, which are:

  • Move Item (mouse drag)
  • Duplicate Item (Ctrl+mouse drag)
    In the former message I misinformed there was a problem with “Delete Tag (Alt+mouse click)”, but this operation is ok. No problem at all with that.

I recorded my screen showing the problem:

Again, the problem was auto-resolved after Windows has been restarted. Just closing/restarting Dynalist didn’t solve it.
Maybe it is a problem happening just in my computer.
I have a collaborator using Dynalist Windows app during full work day, and I already asked her to pay attention and report the problem if it happens in her environment too.

That’s weird… One possibility is that when you closed/restarted Dynalist for the first time, the new version has not been downloaded in background yet.

One way you can now for sure is to check the main menu (menu icon at the top right corner) - About on desktop app. If it says there’s a new version, you’ll be updated to the new version after restarting the app.

I hope that helps!

So I’m a little confused right now, should I considered this bug report fixed or not? :slight_smile:

Could we wait to give the final word it is fixed? I will let you know if the issue is fixed indeed in a couple of days.

Sure, just update me on this thread if it’s fixed or not. If not, how can we repro the issue (if the steps have changed).


No intermitem issues appeared in the last days with Dynalist for Windows.
You can consider it fixed

Thanks for confirming.