Global Android fail

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

I was planning to work in Dynalist during an international flight. This is usually key thinking time for me and I was looking forward do doing some extensive planning with this wonderful tool.
Before getting on the plane, I opened Dynalist on my tablet and ensured it was updated.

Expected result

What do you expect to see after carrying out the steps above?

Access Dynalist.

Actual result

Instead of the expected result, what happened?

But when I attempted to open it offline later, it was blank. Just the “No Document is Open” message.
Previously, I had the rotating infinity sign occasionally, but I could eventually retrieve my work through a refresh. But this time, it didn’t matter how many refreshes I did, it was still blank.

Additional comments

Out of curiosity, I opened my Workflowy app, which was still on my tablet. I hadn’t used it for 45 days, but all the data was still there, and it appeared instantly.

Initially, I was able to open Dynalist on my smartphone. I had to refresh it a couple of times, but eventually it all appeared and I could do some minor work. In the end, though, the same error appeared as on the tablet and I couldn’t access anything. I just got the “No Document is Open” message.

This could be quite serious if I was relying on Dynalist for critical information like hotel bookings. Fortunately, I still use Evernote for that purpose.

Regrettably, I missed out on this important opportunity to do the kind of deep structural work I was hoping to get done. My confidence in Dynalist has also been shaken.

Is it possible to look at the method that Workflowy use for synchronisation on Android and see if it can be adapted to Dynalist?’

I would happily lower my expectations about the development plan in order to secure a more solid base for the app.

The problem remained when I went online. It was only solved by deleting the data and starting again with a refresh.

Update: in the next attempt with offline, I was able to access most documents, but one was stick on the endless infinity loop, despite nearly 30 attempts at refresh. :pensive:

@Shida
@Erica

I’m assuming you’re on the Android app. This seems like a bug we fixed a week ago? What version of the app are you running on?

It’s 1.1.6

One observation that may be useful… Sometimes it can take up to 20 refreshes before the document loads. But also, sometimes a document fails to load though it had just been opened successfully before, while still offline. It does tend to affect larger documents, though the global fail affected all of them.

Hmm, so it’s on the latest version alright. When you say the document doesn’t load, and shows the “no document is open” sign, is it possible to switch to another document without reloading? How about switching back to the same document?

We’re currently stranded outside (in a train station at midnight) without access to our laptops, but I’ll try to repro as soon as we get to our work station.

In the global fail scenario, nothing opens. But when one document goes into the infinity loop, I can usually open another one. But it doesn’t solve the original problem. The problematic document fill fail every time until the adequate number of resets has been done.

I hope you find somewhere to sleep tonight @Shida :worried:

My suspicion is that your local data got screwed up, either through an edge case we didn’t consider, or some kind of corruption. This is my guess because we have over 2k Android app users, so this would have been a widespread problem if it didn’t involved your local data.

A temporary solution I can think of is to get online, sync everything, then reinstall the app, or clear its data. This should get you into a clean state that will hopefully fix your problem.

If that fixes your problem, let us know and we’ll investigate further down that path. We will be keeping an eye for what could cause the problem meanwhile.

Yes, clearing the data does usually fix the problem. I wonder about local corruption, as it happened (and continues to happen) on both the tablet and the smartphone independently. There’s no sign of corruption with any other app.

But I’ll try the uninstalling and re-installing nonetheless, as I am determined to fix this before my next long haul flight and don’t want to revert to Workflowy.

I may be a heavy user.

I trust you found a warm place for the night. :weary:

1 Like

Just an update after the re-installing. There’s been no global fail yet, though some documents have required multiple refreshes before loading, on both tablet and smartphone, while online.

Hmm, have you noticed the same problem on the web version at any time?

Never.

Ok. Could you also clarify the refresh problem? They seem related, so any details help us understand the problem better.

When you say “require refresh”, my current understanding is: You open Dynalist the Android app, and the infinity spinner shows up in the middle, but it never finish unless you forcibly refresh the app using the “refresh” button in the top-right hamburger menu.

Does that describe exactly what you mean by “require refresh”, is there any detail I got wrong?

If that’s the case, I would like to request your permission to access your account. It seems like the problem is reproducible, at least from your account. This would allow us to try and see if we can spot any issues from our test device.

That’s correct. But it’s usually a problem for only a few of the documents, I presume because they are large or they have been recently changed. I give you permission to access the account.

Just to update on this topic, I’ve found out why Kevin’s environment kept failing.

The issue happens when an invisible character “U+2028 LINE SEPARATOR” sneaks in, and our android app didn’t like that. (It couldn’t open the document in offline mode anymore)

I’ve made tweaks to encode it differently so it doesn’t screw up anything when saved. This fix will be included in the next version of Dynalist Android, but you might have to clear dynalist’s app data once it’s updated to permanently fix this issue.

4 Likes

Sounds promising!

1 Like

The Android update now seems to have fixed this issue. Thank you.