Format as code shortcut not working and unable to make a custom shortcut without option key

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

  • select text you want to format as code
  • try to format as code with shortcut ‘Format as code’: command + `

Expected result

What do you expect to see after carrying out the steps above?

  • to format text selected as code

Actual result

Instead of the expected result, what happened?

  • It doesn’t format. It only works when you change the shortcut to something including the ‘option’ key (e.g. option + c). But I don’t like shortcuts including the ‘option’ key.

  • I have already tried the following custom shortcuts without success to format text as code.

    • cmd g
    • cmd shift g
    • cmd j
    • cmd shift j
    • cmd \
    • cmd toggle ( cmd + ' )

Environment

Which operating system are you using? MacBook Pro (15-inch, 2017) version 10.14.6 Mojave
Which browser are you using? Google chrome (having the same issues here)
If you’re using a desktop or mobile app, what’s the version number of Dynalist? 1.2.3
Are you using any third-party scripts for Dynalist, e.g. PowerPack? Nope


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Is not that my “cmd” key is broken or something, I also used the same custom shortcuts mentioned above to change the ‘Make bold’ shortcut feature and they worked. I think something is broken for the format as code feature. The custom shortcuts feature work. Just that something doesn’t work with the ‘Format as code’ shortcut.


Additional comments

Can reproduce. I don’t understand why but I’ll be investigating the specifics.

3 Likes

Seems like it’s caused by an OS shortcut that we tried to block, but as a result all Cmd related keys were blocked.

image

We’ll make a proper fix for it though, hang tight.

1 Like

Hi there,

It’s been a few months. Has there been an update for this? I really want to format as code with a shortcut and use CMD in it :sweat_smile:

Is this bug also in other versions of macOS? e.g. Catalina has it?

I believe it was fixed around December 10th so you should be able to customize it to another key now. It affected all MacOS versions.

Oh I see… I’m currently not using the PRO version to customize the shortcut.

But I can say that the default shortcut is CMD + ` (cmd + backtick or also called grave accent)
and that shortcut is currently not working :confused:

Ah I see. Unfortunately that might still be due to the “Cycle through windows” shortcut on MacOS. I believe you should be able to change it according to

1 Like

That is such a common and fundamental shortcut on macOS - I wish Dynalist would change the shortcut instead of expecting people do disable the Mac global shortcut

I understand what you mean. Unfortunately at this point I don’t think we can change these shortcuts just because people may already be relying on it.

It doesn’t seem like the case for you, but if you had Dynalist Pro, you would be able to customize the shortcut to another key combo.

I actually do have Pro and have changed it :slight_smile:

1 Like