Folders Vanish Entirely

Steps to reproduce

Using Vivaldi or Mac app. Using a shared folder, copy or rename documents that are inside. Accessing the context menu over the document for some reason activates dragging the document, and then the document and/or folder vanishes entirely.

Expected result

My documents not all being deleted, and just being able to access the context menu for the document.

Actual result

All of my documents and the folder containing them disappear.


Which operating system are you using? MacOS. Which browser are you using? Vivaldi. If you’re using a desktop or mobile app, what’s the version number of Dynalist? Newest.

Additional comments

Has happened 2 times with my other personal account. Trying to use as a documents directory for my 30+ person employer but now not sure if I can trust the product to hold up. Have yet to share with a large group but losing documents without a restore/trash function or version history (why is version history tied to documents – what happens if the document is deleted??). Sick of pulling in a backup with missing work and needing to reformat color coding, etc.

Quick question: when you refresh the page does the folders and documents come back?

Once or twice, upon first refresh, it appears if they are still there. But they aren’t accessible. And they aren’t appearing any more.

So, this is the source account that is the original creator, supposed to be hosting the folder. When I access this account I don’t see anything on first load. On the other account, which has the folder shared to it, I see the folder briefly but quickly enough the folder disappears or the webapp freezes while syncing.

I’m really sorry to hear that!

I can’t seem to repro the issue though, might need some more information.

I tried to make a copy of a document inside a shared folder, or rename a document inside a shared folder, and that worked correctly (is that the case for you?). And after that the context menu over each document is working fine.

Am I missing something? I can post a video of me repro’ing it if that helps. I might be missing something.

Also, I spotted an error coming from your client, so we can debug from there as well.

Just want to let you know that we take data loss very seriously. From the looks of it, no data is lost, but the UI is acting funky for some reason (most likely an edge case since I can’t seem to easily repro the issue).

Sorry for having to go through this… could you tell me if this is happening on web or the mac app right now? If it’s the mac app, what’s the version of the app? You can do that by choosing the “About” option in the main menu (menu icon at the top right corner). I just want to make sure we’re working with the same version of the app so it’s easier to investigate the issue.

Sorry again for the inconveniences.

If you right click on a document to open the context menu, for some reason it also activates the “holding” cursor and movement in the context menu also drags the document position. The error seems to occur while in this state. I think something weird is happening with the input and then the document doesn’t know where it’s supposed to be positioned in the list, so it vanishes. I think the data might actually be fine, it’s just the UI not showing the folder. That’s my hunch. But the folder is missing in both accounts which contradicts that hypothesis, because it would be in a different order in my other account.

What error was coming from the client?

It’s happening in the web app in Vivaldi. It’s also happening in the mac app, which I deleted in an attempt to avoid weird cache issues affecting the sync (which is another error I’ll report if it keeps happening on the newest version). So I’m not sure which mac app version was the culprit even though it should have been updated to the newest version.

Question: is the mac app just a skin deployment of a Chrome instance? If I had both the web app open, and the mac app, in the same account or in different accounts, could this cause the issue? I don’t think this was the case each time, but it’s a suggestion if you are trying to reproduce the issue first.

Don’t think that would cause the issue. I personally also use Dynalist this way and haven’t seen this issue, and Dynalist is designed to be able to handle being used in multiple sessions at the same time.

Update on the issue: there are two issues, one for the situation where the disappearing files can come back after refresh (let’s call it “come back”), and another for the situation where the files do not come back and disappear again after appearing for a brief moment (let’s call it “doesn’t come back”).

Now we’ve found a way to repro issue “come back”, and we’ll add safeguards for that.

For issue “doesn’t come back”, we haven’t found a way to repro it (following your steps doesn’t seem to repro it, can’t even repro issue “come back”, I’m guessing your Dynalist environment is a little from ours since the issue has already happened and messed up some things). But we do have an error for it, and I can PM you the stacktrace if you’re interested. We’ll try to fix it, but unfortunately fixing it doesn’t bring the file back, some manual fixing is required to make everything back to normal. I’ll PM you the details.

Issues resolved and we’ve added safeguard for this edge case at both client and server level.

Thanks again, @Tim_Simpson @Tim_Simpson1!