Firefox clipper does not seem to work in Private mode

Steps to reproduce

Open Firefox private session with web clipper added. I cannot do anything, including log in to dynalist or have the add-on recognize I am logged into dynalist, except for type in the available spaces for Title and Note in the pop-up…

Expected result

Out of Private, the web clipper works beautifully and as expected.

Actual result

Nothing. No button functions.

I also tried the text clipper feature in Private and observed that nothing happened when I selected the “clip to dynalist” menu item.


Latest Firefox on Windows 8.1

Additional information

Thank you so much for the Web Clipper on Firefox. I can use it out of Private and it has already saved me a lot of time copying, pasting, and typing. Just thought you might like to know of possible issues in Private mode.

Additional comments

Thanks for catching this!

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile:

I’m really glad I could be of help! :grinning:

1 Like

@Robert1: so I took a look, it looks like the pop-up (the one you see when you click on the icon) doesn’t work because of a structural difference between Firefox and Chrome. We’ll need to rewrite it quite a bit for the pop-up to work properly in Firefox private mode.

Link to this Firefox bug as reported by others:

In the meantime, you can still use the context menu to send webpage URLs and selected to Dynalist though, I just tested and that part seems to work fine.

Thank you for the update. There’s more passion about this issue than I expected to see when I went to the bugzilla link you included. I usually start Firefox in private mode, so I noticed the dynalist issue right away. However, I’m getting along just fine without using Private mode and will enjoy the fix if you ever get around to it, or the structural difference is ever eliminated.

Are the context menu options helpful to you at all?

I am sorry, @Erica. I too quickly dismissed your comment about the context menu working fine in Private, thinking I had correctly tried to use it before I submitted the bug report and that it had failed to copy, and that maybe if it worked for you there was a difference in our Firefox configurations. I am pleased to say I was wrong. The context menu does work in Private as you say. I do use, and expect to use, this feature extensively and it makes everything easier that it works in Private. Thank you again for providing the clipper.

1 Like


I’ll mark this as Fixed for now then. One day the pop-up might magically start working as well :slight_smile: