Expand/Collapse Shortcut not working in iPad OS

Steps to reproduce

Using iPad OS + Apple Smart Keyboard
Using CMD+period as listed here:

Expected result

Expect to expand or collapse a node.

Actual result

Nothing. Focus appears to switch to iOS native copy/paste bar.


iPad Pro running newest iPad OS. Standard Apple iPad keyboard folio.

Extra Info

I don’t know if this shortcut ever worked on iPad previously.

Is any other shortcut working? Or is this the only one not working?

This is the only one I’ve found so far … will raise a new bug ticket if I find any more!

Okay, then there might be something special going on with these two shortcuts then. For example, the iPadOS is using these two shortcuts.

If that’s the case, there isn’t lots we can do, except for changing the shortcut (which will annoying people who’re used to these shortcuts and are not bothered by the iPadOS bug). Since you have Pro, could you try if customizing these shortcuts solves the issue? Thanks!

1 Like

Does that mean upgrading to Pro just to support iPadOS? I think it’s wrong to pay only for that.

Hey @Erica, great idea. I just tested it with CMD+ALT+. (didn’t work) but CMD+, worked a treat. I’m guessing there is an iOS limitation with the . character, since ALT works fine as a shortcut key modifier in other situations.

Thanks for the tip. Works absolutely fine for me but a shame that @coffee_saotome can’t make use of the same workaround. Totally agree with you that changing the default shortcut is probably not the solution, but could it make sense to add (for example) ALT+, as a dual shortcut?

(But then I guess you risk irking users who could be using CMD+, for something else. It’s a tough life, product!)

Sorry I wasn’t suggesting that. I was only suggesting it because @JohnLi already upgraded (maybe for reasons other than custom shortcuts). If you were the OP I wouldn’t have suggested that.

Before we can do anything else, it is a workable temporary solution for @JohnLi, don’t you think? :slight_smile:

Hi John, I googled around for iPad OS shortcuts, and learned that there are 30+ new shortcuts. Among them I didn’t find Cmd+., maybe it’s a default shortcut?

I’d love to learn what Cmd+. is used for in iPad OS and whether iPad users can customize it, but I’m not an in-depth iPad user myself. Maybe you’ll know better? :smile:

I’m sorry too. I said too much.
I am using Dynalist on iPadOS.
On iPadOS, the dot key cannot be used as a shortcut key.
This is iPadOS specification.
The current solution is to upgrade to DynalistPro and customize shortcuts. But I can’t pay for it alone.
Can you use it with other key combinations? Please.

Hey @Erica - so it seems the CMD+. combination on iPad is pretty handy as is. It functions in a similar way to ESC meaning you can toggle “edit” and “view”. That is, hitting the combo hides the cursor and the current node is rendered. Doesn’t seem like it can be customised, and it doesn’t seem to act as a global ESC key, which is odd.

Thanks for catching this!

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile:

It would seem like on iOS, Apple specifically hacked the “CMD + Period” combination to trigger an “ESC” key (without the command modifier). This was done apparently because some iOS keyboards don’t have an ESC key???

We’ll put a hack in place to detect this sequence (CMD + ESC but without the CMD modifier) and replace this with the proper CMD + Period. If you have a keyboard with an ESC key, it will still work correctly because there won’t be a CMD pressed before it.

Fix will be out in the next patch

1 Like