Dynalist non-functional!

I work with both the Linux Desktop (.deb) and the iOS app

  1. It worked well the first two weeks - then pro trial finished and since then the following happens. So weel I actually recommended it to others!!!

  2. Pro trial finished and sync issues started - but then I also started loosing new documents. I also done a rearranging fo my folders on my desktop and it did not sync to my iOS app.

  3. further experimenting brought the following:

  4. Open a fresh instance of Dlist - I see a list of folders and files as long as I do not do any thing like add new document I can close the instance.

  5. as soon as I add a new documents - I cannot close dynalist and the only way to close it is via command line xkill or kill pid

  6. then the freshly created document disappears.

So actually dynalist at this point in time is not working.

I uninstalled it from both my iphone and my laptop
and then reinstalled -
same results

Steps to reproduce

Open a fresh instance of dynalist with the linux desktop app
click add new document
type content in new document

Expected result

I expect 3 things

  1. To be able to save the document
  2. to sync it with my ios
  3. to be able to close the dynalist instance with ctrl+q or just clicking the x to close the window

Actual result

Instead of the expected result, what happened?

I cannot close the document - only kill it with command line

it does not sync

it gets lost after closing it with command line


OS linux mint 18.3 dynalist 1.1.9

iOS on iphone SE latest app from app store

Additional information

I can confirm - Dynalist on Firefox syncs with iOS!

I feel as if the problem came about after I created a big re organizing of my folders.
Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Additional comments

Hi @kelsang_sherab,

It looks like the local data might have been corrupted somehow.

Could you please try the following:

  1. Make sure local data are saved (you can export local unsaved changes to OPML or plain text using the “Export” option in the item menu);
  2. Exit the desktop app;
  3. Delete everything under ~/.config/Dynalist/dynalist;
  4. Restart the app.

That should pull a fresh copy from the server and fix the issue. After that, paste or import the local changes to continue.

Let me know if that fixes it!

P.S. Do you think the issue happened at the same time at your free trial expiration? Trying to figure out if that might affect data corruption somehow.

Hi @Erica
Thanks for your suggestions.
they seemed to have worked!!

I am not sure exactly what happened.
I think it seems to have corresponded with the end of my pro trial. But also around the same time I’ve done a massive re-arraning of my folders on my Desktop app - and maybe this had something to do with it?

Thanks again for your reply and solution!

A massive re-arranging sounds like the trigger. We still can’t seem to determine the culprit behind rare cases like this, but I’ll let our engineer know and see if he can think of anything.

Thanks for the information!