Dynalist app no longer syncs on Android 6

Steps to reproduce

Clean install of Dynalist app (1.3.3) on Android 6.0 device. Log in to Dynalist Pro account. Confirm device has normal internet connectivity.

Expected result

Normal app functionality; Dynalist has been working - with the same app and Android versions - until a few days ago.

Actual result

Dynalist logs in, but sits for ever on spinner when trying to open a document.

If I close and re-open Dynalist, the document list is shown and reflects changes made on other devices, but the documents themselves still cannot be opened (again sits indefinitely on spinner).

If I create a new document on the problem device, the document appears on other devices, but with no content.

Environment

Mobile app from Play Store
Hardware: Lenovo TAB3
Android version: 6.0
Dynalist app version: 1.3.3


Additional information

This was working until a few days ago - I haven’t made any changes do the device; as far as I know it’s been running the same Android and Dynalist versions throughout.

On Friday I noticed changes made within documents on other devices had stopped syncing to the tablet; I’d been using it extensively the fortnight before with no problem. I’ve tried logging out and in, clearing the app cache, then re-installing entirely; same result in all cases.

It does log in to my account correctly; the issue appears to be with syncing document content in either direction. I don’t have any issue on any other devices (desktop, web, more recent Android).

The Dynalist web application (i.e. opened in Chrome on the same Android 6.0 device) works fine - only the actual Dynalist Android app has problems.

Sorry for the late reply, team got taken down by the flu :frowning:

So do you edit on the Android app, or do you only view the data on the Android app?

I’m experiencing exactly the same symptoms on Android 9. Upon new installation, the document list gets synchronized (although only after closing and restarting the app), but none of the documents ever gets displayed, only the spinner spins forever. Even if I create a new document in the app, the app itself isn’t able to display it, just shows the spinner.

Not sure how, but the problem has somehow fixed itself. Was it a server problem? I tried a few things like setting the WebView component to Chrome in Developer Options, but I’m not sure that had any effect. Anyway, the problem is gone for now.

Hmm, if you have really large document, I guess it can take a few minutes to download and display them all at first.

Is that the case?

No, only a few small documents, and I waited for several hours. They should have appeared immediately.

The synchronization problems have appeared again. Not sure what’s happening. Looks like this is too unreliable.

@Andras_Szilagyi: As a temporary workaround, could you please try opening the left pane, and choose any document? This should fix the issue.

This issue will be fixed in the next update. Sorry about that!