Doc shared with me is Locked in Desktop App.. Even with Manage Sharing ON

resolved

#1

A Free User shared a doc with me, while I use my Google Suite email address to proxy into Dynalist. The doc shows fine and unlocked in my devices and Chrome, but in my desktop app it appears to be locked and I cannot edit it there, although it is syncing fine. I tried resizing the page, etc. and nothing is removing the locked status in the desktop app only. Please help.


#2

Can you show me the locked status? Is that a lock in the file icon like this?

image


#3

Yes… For my desktop app, the icon also show at top left on the detail page. The icon is non-clickable, while the SAME DOCUMENT does NOT have a lock while using Chrome, iPad or iPhone… and I’m set and I’m able to manage sharing. Weird.


#4

Hmm, it looks like the local data might have been corrupted somehow.

Could you please try the following:

  1. Make sure local data are saved (you can export local unsaved changes to OPML or plain text using the “Export” option in the item menu);
  2. Exit the desktop app;
  3. Rename the following folder “data” to “data-backup”
    Windows: %APPDATA%/Dynalist/dynalist/data
    Mac: ~/Library/Application Support/Dynalist/dynalist/data
    Linux: ~/.config/Dynalist/dynalist/data
  4. Restart the app.

That should pull a fresh copy from the server and fix the issue. After that, paste or import the local changes to continue.

Let me know if that fixes it!


#5

Absolutely, fixed it! Thanks Erica!


#6

Thanks for the update! That would mean the local version of the document somehow got out of date. Glad it’s sorted now! :slight_smile: