Dates showing up garbled if no time entered


I have encountered a bug when I enter a date on dynalist, using an !. If I enter a time with the date, it works perfectly. But if I don’t enter a time, but just a date, I get garbled text. Could you fix this?


Which operating system are you using? - windows 10
Which browser are you using? - Opera, but it does the same thing on Chrome
If you’re using a desktop or mobile app, what’s the version number of Dynalist? I’m using the web version. But it has the same error on the app.
Are you using any third-party scripts for Dynalist, e.g. PowerPack? n o.

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Additional comments

I go to chrome. I type !. Date picker pops up. I click a date. I click done. I see

  • !(2021-12-16)

What is different for you?

Yes, that’s how it looks if and only if you hover over that line. But if you are on a different line, one of two things happens: (1) if you enter a date AND time, it looks like this: Calendar icon followed by “In 2 days, 9 am.”; (2) BUT if you enter just a date and no time (i.e., !(2021-12-16)), it looks like this: calendar icon followed by “g1r239@g0ami12/16/”

The latter is an error.

And – I have more data! – this error doesn’t happen if I hand type the !(2021-12-16). It only happens if I type in the !, and then pick the date from the calendar that pops up, and leave the time as “all day,” without specifying a specific time.

And, relentless experimenter that I am, I have more data still.

This generates that garbled text: !(2021-12-15)

This generates the correct text: !(2021-12-15 )

Open an incognito windows in Chrome and log in to dynalist and see if it still happens.

This would tell you if an extension is responsible.

Yes, it happens in incognito chrome. It happens in regular chrome. It happens in Opera, which is the browser I use for Dynalist generally. It’s a bug.

I found the problem and fixed it. (There is a box on pro settings that lets you change the way dates appear without times. Oddly, some garbled text got in there.)

1 Like