Cursor does not advance to next line with right arrow button when line ends in @tag

Steps to reproduce

Create an item that ends with an @ tag, e.g.
test dynalist item @test
Move cursor to part way through this item, e.g between the ‘y’ and the ‘n’.
Repeatedly press the right arrow key until the cursor gets to the end of the line. Press the right arrow key again.

Expected result

Cursor moves to the next line.

Actual result

Cursor doesn’t move from end of the line, sometimes.


Windows 10 Desktop, Chrome

Additional information

This doesn’t always happen. I can take the same bullet point and move it around Dynalist, and some places the cursor will get stuck at the end of the line and others it won’t. It also sometimes happens for # tags. I don’t know what the pattern is on when the cursor will get stuck.

Also, pressing esc does not exit the selection menu for a tag, and does not exit editing mode when the tag selection menu is active.

Additional comments

I tried what you described, but couldn’t make the bug happen on my end. Do you think there’s anything that can help us reproduce the issue?

Anything about your habit of doing this might be helpful. I might have tried something that’s the same as how you described it, but dramatically different from how you actually do it. For example, how fast do you press the right arrow key? Do you hold it or not? And how often do you see this bug, approximately how many times in 100 times? I tried ~10 times and haven’t seen it happen.

I see it happen a lot on a particular list I use; it’s pretty annoying. The list has 191 items. The first tag, which is a tag where I see this problem, occurs 101 times on the list.

It doesn’t happen if there’s a space after the tag. It happens whether I press the right arrow key quickly, slowly, or press and hold. I don’t know how often I see it out of 100 times because when it doesn’t happen, I don’t notice that. I only really notice when the bug comes up, not when it doesn’t come up. It seems to happen mostly on the one particular list I mentioned above.

I’m practically not using tags because of this blocking behaviour. Up, down (in typical circumstances) and right (in described situation) arrow keys are useless because of this tag popup, and esc - the button you can use anywhere else to loose focus, is deactivated here too. I wish there is an option to disable this popup completely, if you consider this blocking as a “feature” and not a bug, @Erica

Add those two items to a list and you will see this bug in the first line:
lorem ipsum #cache
lorem ipsum #cached

Ah, I was able to repro it with those nodes.

Yes, I was trying to repro with a space at the end, which is I didn’t see the issue as described by @Mark_Eichenlaub .

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile: