Ctrl+Shift+0 doesn't work as keyboard shortcut

closed

#1

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Click the settings gear icon.
Select the “keymap” tab.
Try to input “Ctrl+Shift+0” (using the 0 in the number row, not the number pad, for which “Shift+0” is converted to “Ins”, and the shortcut behaves as expected).

Expected result

What do you expect to see after carrying out the steps above?

The shortcut set to either “Ctrl+Shift+0” or “Ctrl+)”.

Actual result

Instead of the expected result, what happened?

It doesn’t register the input, continues waiting for me to input a key combination. “Ctrl+Shift+9”, “Ctrl+Shift+8”, etc. all work correctly, only “Ctrl+Shift+0” fails.

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Windows 7
Chrome Version 72.0.3626.121 (Web app).


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments

Again, this is the 0 (Zero) key on the number row, not the 0 key on the number pad. The rest of the number row works correctly, but not the 0.


#2

Our shortcuts don’t allow for remapping shortcuts to Ctr+Shift+0.

As you’ve said, Ctrl+Shift+1 - Ctrl+Shift+9 works, but Ctrl+Shift+0 is not available to become a shortcut.

This is because the key combinations for it simply cannot be used for apps on Windows 7+


#3

Seems like an OS issue but I think it might work if you change the Windows language switching hotkeys according to this: https://superuser.com/questions/604790/how-to-disable-ctrlshift-keyboard-layout-switch-in-windows-8