Copied bullets lose indentation on first copy attempt (but retain indentation on subsequent attempts)

Steps to reproduce

  1. Create a new document with this content
  • lol
    • test
  1. Highlight the bullets with text and press Ctrl-C.
  2. Go to the empty bullet and type Ctrl-V.

Expected result

What do you expect to see after carrying out the steps above?

  • lol
    • test
  • lol
    • test

Actual result

Instead of the expected result, what happened?

  • lol
  • test
  • lol
    • test

But if I copy the same text and paste again, the indentation is usually retained.

Environment

I get this with the desktop app on Linux and the web app on Chrome on macOS. I haven’t tested other environments. It’s been a bug for many months, and I keep the desktop app up to date.

Sadly I can’t repro on Windows. It might be a Linux-exclusive bug but I doubt it.

Any other linux user can help verify this?

It does seem as though I can reproduce the problem more reliably on Linux than on macOS. Here’s a screen recording taken on my Mac. After I made the recording, I couldn’t reproduce the bug again, even after reloading the Web page or app. But I can consistently reproduce it on Linux (Chrome and app).

Any chance you can try to paste into this clipboard tester box when you’re on Linux and can consistently reproduce this?
https://dynalist.io/clipboard

Let us know what shows up.

When I tried copying the indented version of “out in 1 in 2,” it became flat:

image

And this is what the clipboard-test output looked like:

image

This is what it looked like when I tried copying again and it worked:

So sometimes it’s copying plain text and sometimes HTML. Interesting!

Wait so, I’m not sure I understand this - Did you have to copy again to make it fixed, or do you just paste, and paste again and the 2nd time it works?

I had to copy it a second time to get it to work.

See any errors in the JS console? I’m at a loss as to what this could be…

If that’s all the info we have I might need to spin up an ubuntu box to test later