Complete link item

answered

#1

Any way to cross off links. At the moment I have a task list made up of links to a master information list. I want to cross off the link task, but it doesn’t cross off.


#2

Not sure I understand what you meant.

So there’s a list of tasks, each linked to another item, is that right? And when you check off the task, checking doesn’t work? Is that what the issue is?


#3

Erica, I think John means that when a crossed-off node contains a link, the link doesn’t look crossed off:

image


#4

Exactly this. My work around is just to copy some text before the link, so not a huge deal


#5

Ah, I see. It is grayed out though, I guess that visual distinction is not noticeable enough?


#6

My links gets crosses off normally though.

For the time being you can try encasing the links in ~~[text](url)~~


#7

Oh really? I was able to reproduce this issue.

He has a Dynalist internal link, not just a normal [link](www.google.com) though.


#8

Well, putting the code into the item is another issue for me, because I like to scroll through them via keyboard, which means whatever I select gets all the ugly code. That’s another topic. I love dynalist, just a couple of features for consideration in the future perhaps? All is well :slight_smile:


#9

My bad. I thought a normal link was being talked about. Crossing internal link doesn’t work.


#10

Yep, we’ll consider it, sorry about that!

I think the issue is the same with all inline items, such as images, files, dates, and of course, as you pointed out, internal links. I believe in the beginning we thought add the strikethrough would obscure the text too much, but now I think about it, consistency is important too.

Moved your post to the feature section too, by the way.


#11

Perhaps we could use a checkbox, wherever there’s an internal link? And if the existing grey checkbox is replaced with a brightly coloured box, it would be clearly visible.

The trouble with this approach is that all the children will also acquire checkboxes, and those cannot be turned off. :confused:

Artboard%201


#12

Thanks. Also, I just noticed that searches don’t show results for internal links.


#13

Yeah, if you search for the title, it’s technically not part of the plain text content.


#14

no problem, i just put the text in front of the link to solve both problems. Thanks