Can't paste screenshot in Safari

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

  1. Press Press Shift-Command-4 to copy screen selection to clipboard.
  2. Paste into a selected Dynalist node.
  3. In Chrome/FF, i In Safari, nothing happens.

Expected result

What do you expect to see after carrying out the steps above?

It pastes something like ![Pasted image](https://dynalist.io/u/mZjkBAMuPZodmgkDZ-h6Tnc).

Actual result

Instead of the expected result, what happened?

Nothing happens

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Safari only.


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments

It’s an issue with Safari, which has been widely reported not working for popular websites such as Gmail, Facebook, and even Discourse.

See the following links:
https://discussions.apple.com/thread/7727011


https://meta.discourse.org/t/paste-images-in-composer-not-working-in-safari/24632

I faced the same issue. I use safari browser on my iPhone and I can’t paste the screenshot in my safari. I couldn’t figure out this problem. Maybe safari can’t verify the identity of the website. I need a solution.

Try the mobile app. Did you read the thread by any chance? It’s a Safari bug and unfortunately we can’t do much about it.