Can I insert a link to a file or folder stored locally on my c: drive?

resolved

#1

I’m guessing I could insert Dropbox links obtained from Dropbox. What I’m looking for is to have link go to my c: drive, not to the Dropbox website, which is kludgy.

Thanks,
Alex


Linking to Local Files
#2

Hi Alex,

You can certain link to it, but on the web version, browsers do not allow websites to access local files for security reasons. You can certainly use Dynalist to store local links though. You just have to manually copy and paste the link to explorer to make it work.

We will try to make accessing local files work on the desktop version in the near future.


#3

Hi, has this now possible?


#4

I don’t know myself, I haven’t heard anything back for quite some time. I think the issue is whether it’s possible using the desktop version of Dynalist, I think it’s not possible in the web version, except to link to online files, e.g. Dropbox or GoogleDocs. But I wanted to have links to my local drive. Let’s see what Erica (or someone from Dynalist) says.


#5

@Alex_Moss

Yes, it’s possible in the latest version of the desktop now. Just use the [link name](local link) format.


#6

Thanks, using your information I can reference a file, but I cannot open it from dynalist. Am I doing something wrong? I would like to click on the link and open the file…


#7

Weird, the file should just open by itself. I just tried with a PDF file and it opened in my primary PDF reader software.

Could you let me know your desktop app version? You can find that in main menu (menu icon at the top right corner) - “About”.

And if you don’t mind, what’s the file path you’re using? It might be caused by file path too, like if it contains some kind of special character.


#8

Fyi, it works for me too, using the desktop app and not the browser. This is extremely handy, very pleased to see it!


#9

[CRM](D:\ABC - ABC\ABC@ABC\Gestão ABC\Comunicação\crm.pptx)

(I replaced some strings with ABC but left the general format and some language-specific characters)

I’ve tried with a simple path and simple filename and it works.

I’m using Dynalist 1.0.54.


#10

Could be from the non ASCII characters…

Could you please file a separate bug for this one? Thanks in advance :slight_smile:


Linking to Local Files
#11

It is indeed a non-ASCII character problem. Should be fixed ASAP.

But it is still too inconvenient to get a copy of the whole file path by pressing Shift+Right_Mouse etc. and then remove redundant quotation marks, etc. etc. Why don’t you just let us drag and drop the file and then choose either upload to the server or have a local link. That would make it vastly more useful. Thanks.


#12

@YPark Thanks for posting the bug! Really appreciate your opening a new thread rather than adding to this thread.

You can open a feature request for this part if you’d like. Thanks in advance!