Attachments don't open

Steps to reproduce

Click on attachment link, blank browser page opens

Expected result

To see the attachment, in this case a PDF

Actual result

Nothing visible


Which operating system are you using? Mac 10.15.6
Which browser are you using? Firefox 81.0.1
If you’re using a desktop or mobile app, what’s the version number of Dynalist?
Are you using any third-party scripts for Dynalist, e.g. PowerPack? No

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Additional comments

Noticed that the same happens from the download manager

Any chance you can give us more details? Perhaps with the link to the file if it’s not sensitive (or private message me if it is).

:blush: Well, it’s not happening quite as I thought…

  • On the Mac and Web the files are downloading, not opening to view which is what I was expecting. So, while I thought that nothing was happening, they were in fact piled up in my Downloads folder. Is that the correct outcome?
  • On iPadOS I am taken to a Dynalist web page with a message:

You are not allowed to access this file.
Go to homepage

  • On iOS seems to work as expected. Click the link, the document opens

In case it’s related, Erica changed the email address on the account (at my request) a week or so ago.

I noticed that, in the settings dropdown, my previous email address is showing despite being logged in with the new one.

I believe that shows the email for the account you’re logged into.

Are you sure you don’t have two accounts? The wrong email plus the access denied error makes it sound likely. (Because the other account is not the owner of that attachment, thus the permission error.)

A few days ago (1st Oct) you responded to my request to change my account email address. You said you would make the change once I had confirmed by email from the new address. I did that. So I am wondering if something has gone wrong in that process? I am logging in with the new email address but it appears as the old one. As if in some way they are both live.

I don’t think email changes would affect permissions to access files. Does it show the same account across all the platforms that work/doesn’t work to open the file? If it’s showing the wrong account, does a logout/login fix the issue?

Where do the credentials that allow file access come from? I am logging in with one address but the account is showing a different one. Wouldn’t that affect access to the files? I have tried logging out and back in from all platforms. I also tried a different browser and incognito in case there was a cache.

Just wondering if there’s anything further on this? Did @Erica change the email? If so, why am I still logged in with the old email?

Might be because the email is cached on the client so it didn’t get updated correctly. Was this on the web app or desktop app?

Both. And both iOS too.

Sorry about the delay, I’ve just updated your email for you. Sorry about that!

Thanks, working now…